Bug 1293116 - yum install vdsm fails due to some dependency issues
yum install vdsm fails due to some dependency issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: releng (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.0-beta
: ---
Assigned To: Joey Boggs
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 07:24 EST by Roman Hodain
Modified: 2016-04-19 21:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:29:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Rel-Eng
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Hodain 2015-12-20 07:24:31 EST
Description of problem:
It is not possible to install vdsm for RHEV 3.6 beta due to the missing
dependency of libvirt-lock-sanlock-1.2.17-13.el7.x86_64.


Version-Release number of selected component (if applicable):
    RHEV 3.6 beta2

How reproducible:
100%

Steps to Reproduce:
    Install Fresh RHEL 7.2
    Then install vdsm:
        # subscription-manager register
        # subscription-manager subscribe --pool=8a85f9833e1404a9013e3cddf95a0599
        # subscription-manager repos --disable=*
        # subscription-manager repos --enable=rhel-7-server-rpms --enable=rhel-7-server-rhev-mgmt-agent-beta-rpms
        # yum install vdsm

Actual results:

--> Finished Dependency Resolution
Error: Package: libvirt-lock-sanlock-1.2.17-13.el7.x86_64 (rhel-7-server-rhev-mgmt-agent-beta-rpms)
           Requires: libvirt-daemon = 1.2.17-13.el7
           Available: libvirt-daemon-1.1.1-29.el7.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.1.1-29.el7
           Available: libvirt-daemon-1.1.1-29.el7_0.1.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.1
           Available: libvirt-daemon-1.1.1-29.el7_0.3.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.3
           Available: libvirt-daemon-1.1.1-29.el7_0.4.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.4
           Available: libvirt-daemon-1.1.1-29.el7_0.7.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.7
           Available: libvirt-daemon-1.2.8-16.el7.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.8-16.el7
           Available: libvirt-daemon-1.2.8-16.el7_1.1.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.1
           Available: libvirt-daemon-1.2.8-16.el7_1.2.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.2
           Available: libvirt-daemon-1.2.8-16.el7_1.3.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.3
           Available: libvirt-daemon-1.2.8-16.el7_1.4.x86_64 (rhel-7-server-rhev-mgmt-agent-beta-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.4
           Available: libvirt-daemon-1.2.8-16.el7_1.5.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.5
           Available: libvirt-daemon-1.2.17-13.el7.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.17-13.el7
           Installing: libvirt-daemon-1.2.17-13.el7_2.2.x86_64 (rhel-7-server-rpms)
               libvirt-daemon = 1.2.17-13.el7_2.2


Expected results:

    vdsm get installed

Additional info:

This error is also seen when enabling all channels:

**********************************************************************
Dependency resolving failed due to missing dependencies.
Some repositories on your system are disabled, but yum can enable them
and search for missing dependencies. This will require downloading
metadata for disabled repositories and may take some time and traffic.
**********************************************************************

Enable all repositories and try again? [y/N]: y
...
--> Finished Dependency Resolution
Error: Package: libvirt-lock-sanlock-1.2.17-13.el7.x86_64 (rhel-7-server-rhev-mgmt-agent-beta-rpms)
           Requires: libvirt-daemon = 1.2.17-13.el7
           Available: libvirt-daemon-1.1.1-29.el7.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.1.1-29.el7
           Available: libvirt-daemon-1.1.1-29.el7_0.1.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.1
           Available: libvirt-daemon-1.1.1-29.el7_0.3.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.3
           Available: libvirt-daemon-1.1.1-29.el7_0.4.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.4
           Available: libvirt-daemon-1.1.1-29.el7_0.7.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.1.1-29.el7_0.7
           Available: libvirt-daemon-1.2.8-16.el7.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7
           Available: libvirt-daemon-1.2.8-16.el7_1.1.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.1
           Available: libvirt-daemon-1.2.8-16.el7_1.2.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.2
           Available: libvirt-daemon-1.2.8-16.el7_1.3.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.3
           Available: libvirt-daemon-1.2.8-16.el7_1.4.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.4
           Available: libvirt-daemon-1.2.8-16.el7_1.5.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.8-16.el7_1.5
           Available: libvirt-daemon-1.2.17-13.el7.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.17-13.el7
           Installing: libvirt-daemon-1.2.17-13.el7_2.2.x86_64 (rhel-7-server-aus-rpms)
               libvirt-daemon = 1.2.17-13.el7_2.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Note You need to log in before you can comment on or make changes to this bug.