Bug 1293119 - shinken-arbiter includes configuration files of other daemons
shinken-arbiter includes configuration files of other daemons
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: shinken (Show other bugs)
epel7
noarch Linux
low Severity low
: ---
: ---
Assigned To: David Hannequin
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 07:45 EST by rasoso
Modified: 2016-10-21 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-21 05:08:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rasoso 2015-12-20 07:45:35 EST
Description of problem:

shinken-arbiter package includes configuration file of shinken-receiver /etc/shinken/receivers/receiver-master.cfg
(as well as other daemons configuration file).

The receiver daemon is not mandatory in shinken, so there it is not required to install this package.

When the package is not installed, errors appear in the logs:

[1450614953] ERROR: [Shinken] [All] Dispatching failed for receiver receiver-master

Version-Release number of selected component (if applicable):

shinken-arbiter-2.4.2-1.el7.noarch

How reproducible:

always

Steps to Reproduce:
1. do not install shinken-receiver
2. check errors in the logs

Actual results:

# for i in `find /etc/shinken/ -name "*-master.cfg"`;do echo $i;rpm -qf $i;done
/etc/shinken/arbiters/arbiter-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch
/etc/shinken/brokers/broker-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch
/etc/shinken/pollers/poller-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch
/etc/shinken/reactionners/reactionner-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch
/etc/shinken/receivers/receiver-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch
/etc/shinken/schedulers/scheduler-master.cfg
shinken-arbiter-2.4.2-1.el7.noarch



Expected results:

The configuration files of each daemon are in their own package, not the shinken-arbiter package.

Additional info:
Comment 1 David Hannequin 2016-03-20 15:26:57 EDT
Hi,

I test on centos 6 with shinken version 2.4.2-3 and directory /var/run/shinken is create.

Best regard
Comment 2 David Hannequin 2016-03-20 15:30:29 EDT
My bad wring bug number.
Comment 3 David Hannequin 2016-10-21 05:08:56 EDT
Hi,

It's not a bug. Shinken Arbiter role is to dispatch monitoring configuration for every shinken's daemon. 

 
Shinken daemon are configuration file in directory /etc/shinken/daemon.

Best regard

Note You need to log in before you can comment on or make changes to this bug.