Bug 1293126 - SELinux is preventing beam.smp from 'open' accesses on the file /var/lib/rabbitmq/.erlang.cookie.
SELinux is preventing beam.smp from 'open' accesses on the file /var/lib/rabb...
Status: CLOSED DUPLICATE of bug 1293123
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1eebef3a46dab74d6245e13d913...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 08:33 EST by autarch princeps
Modified: 2016-01-04 06:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 06:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description autarch princeps 2015-12-20 08:33:02 EST
Description of problem:
SELinux is preventing beam.smp from 'open' accesses on the file /var/lib/rabbitmq/.erlang.cookie.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es beam.smp standardmässig erlaubt sein sollte, open Zugriff auf .erlang.cookie file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
Target Context                system_u:object_r:rabbitmq_var_lib_t:s0
Target Objects                /var/lib/rabbitmq/.erlang.cookie [ file ]
Source                        beam.smp
Source Path                   beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-157.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.7-300.fc23.x86_64 #1 SMP Wed
                              Dec 9 22:28:30 UTC 2015 x86_64 x86_64
Alert Count                   3
First Seen                    2015-12-04 14:14:04 CET
Last Seen                     2015-12-20 14:27:02 CET
Local ID                      fe9ae034-4efb-4cae-aa2c-c49681f1d0c0

Raw Audit Messages
type=AVC msg=audit(1450618022.550:786): avc:  denied  { open } for  pid=13633 comm="beam.smp" path="/var/lib/rabbitmq/.erlang.cookie" dev="sda5" ino=102077060 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:rabbitmq_var_lib_t:s0 tclass=file permissive=1


Hash: beam.smp,logrotate_t,rabbitmq_var_lib_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-157.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.7-300.fc23.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-01-04 06:40:30 EST

*** This bug has been marked as a duplicate of bug 1293123 ***

Note You need to log in before you can comment on or make changes to this bug.