Bug 1293356 - recommend.conf is not labeled as a config file in tuned.spec
recommend.conf is not labeled as a config file in tuned.spec
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 09:19 EST by Jeremy Eder
Modified: 2015-12-21 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 10:31:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Eder 2015-12-21 09:19:37 EST
/usr/lib/tuned/recommend.conf is not labeled as a config file in tuned.spec.
Is this because it is not expected that users customize this file?

Otherwise I think it should be labeled as a config file.

Description of problem:
[root@tuned-demo ~]# rpm -q tuned
tuned-2.5.1-4.el7_2.1.noarch

[root@tuned-demo ~]# rpm -qc tuned
/etc/tuned/active_profile
/etc/tuned/bootcmdline
/etc/tuned/tuned-main.conf
Comment 2 Jaroslav Škarvada 2015-12-21 09:45:55 EST
It is not customizable config file, it shouldn't be changed by users, also it is not preserved during updates. Users can customize recommend.conf by copying it to the /etc/tuned directory. The /etc/tuned/recommend.conf takes precedence (is processed last), so users can also use it to just override individual parts of the default config.
Comment 3 Jeremy Eder 2015-12-21 10:31:57 EST
Got it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.