Bug 1293429 - WARNING: CPU: 1 at drivers/gpu/drm/i915/intel_pm.c:3391
WARNING: CPU: 1 at drivers/gpu/drm/i915/intel_pm.c:3391
Status: CLOSED DUPLICATE of bug 1293427
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 13:23 EST by Justin Albstmeijer
Modified: 2016-01-04 08:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 08:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Albstmeijer 2015-12-21 13:23:47 EST
Description of problem:


My Asus Zenbook UX303UA  with bios version 202 is very unstable on Fedora 23.
For that reason I'm looking in to logged errors and reporting them.

Version-Release number of selected component (if applicable):


kernel-4.2.7-300.fc23.x86_64

How reproducible:


Steps to Reproduce:
1. start laptop
2. work on it and check logs

Actual results:

Dec 19 22:00:05 localhost kernel: ------------[ cut here ]------------
Dec 19 22:00:05 localhost kernel: WARNING: CPU: 1 PID: 1620 at drivers/gpu/drm/i915/intel_pm.c:3391 skl_update_other_pipe_wm+0x1de/0x1f0 [i915]()
Dec 19 22:00:05 localhost kernel: WARN_ON(!wm_changed)
Dec 19 22:00:05 localhost kernel: Modules linked in:
Dec 19 22:00:05 localhost kernel: ecryptfs encrypted_keys trusted rfcomm ccm cmac fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_connt
rack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_broute bridge stp llc ebtable_nat ebtables ip6table_security ip6table_raw ip6tabl
e_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_security iptable_raw iptable_mangle iptable_nat nf_conntrack_ipv4 nf_de
frag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack bnep arc4 iwlmvm snd_hda_codec_hdmi snd_hda_codec_conexant mac80211 snd_hda_codec_generic intel_rapl x86_pkg_temp_thermal coretemp 
snd_hda_intel kvm_intel snd_hda_codec iwlwifi snd_hda_core snd_hwdep kvm asus_nb_wmi snd_seq asus_wmi sparse_keymap vfat fat uvcvideo btusb
Dec 19 22:00:05 localhost kernel: snd_seq_device videobuf2_vmalloc btrtl cfg80211 snd_pcm btbcm videobuf2_core btintel videobuf2_memops v4l2_common bluetooth videodev snd_ti
mer uas usb_storage media snd joydev processor_thermal_device rfkill shpchp intel_soc_dts_iosf i2c_i801 iosf_mbi soundcore wmi int3402_thermal pinctrl_sunrisepoint int3403_t
hermal pinctrl_intel int340x_thermal_zone acpi_als tpm_crb kfifo_buf tpm industrialio int3400_thermal acpi_thermal_rel acpi_pad nfsd auth_rpcgss nfs_acl lockd grace sunrpc d
m_crypt i915 crct10dif_pclmul crc32_pclmul crc32c_intel i2c_algo_bit drm_kms_helper drm serio_raw video i2c_hid
Dec 19 22:00:05 localhost kernel: CPU: 1 PID: 1620 Comm: gnome-shell Tainted: G        W       4.2.7-300.fc23.x86_64 #1
Dec 19 22:00:05 localhost kernel: Hardware name: ASUSTeK COMPUTER INC. UX303UA/UX303UA, BIOS UX303UA.202 08/27/2015
Dec 19 22:00:05 localhost kernel: 0000000000000000 0000000015183fe5 ffff88025d903628 ffffffff81772baa
Dec 19 22:00:05 localhost kernel: 0000000000000000 ffff88025d903680 ffff88025d903668 ffffffff8109e4b6
Dec 19 22:00:05 localhost kernel: ffff88025d903730 ffff88025d9037d4 ffff880266ed2000 ffff880266ed1000
Dec 19 22:00:05 localhost kernel: Call Trace:
Dec 19 22:00:05 localhost kernel: [<ffffffff81772baa>] dump_stack+0x45/0x57
Dec 19 22:00:05 localhost kernel: [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
Dec 19 22:00:05 localhost kernel: [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
Dec 19 22:00:05 localhost kernel: [<ffffffffa00cbc5e>] skl_update_other_pipe_wm+0x1de/0x1f0 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffffa00cbe2b>] skl_update_wm+0x1bb/0x740 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffff810df990>] ? wake_atomic_t_function+0x70/0x70
Dec 19 22:00:05 localhost kernel: [<ffffffffa00cf42e>] intel_update_watermarks+0x1e/0x30 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffffa01354e8>] haswell_crtc_enable+0x488/0xa90 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffffa0131d86>] __intel_set_mode+0x916/0xb60 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffffa0138c86>] intel_crtc_set_config+0x2b6/0x580 [i915]
Dec 19 22:00:05 localhost kernel: [<ffffffffa0039306>] drm_mode_set_config_internal+0x66/0x100 [drm]
Dec 19 22:00:05 localhost kernel: [<ffffffffa003d819>] drm_mode_setcrtc+0x3e9/0x500 [drm]
Dec 19 22:00:05 localhost kernel: [<ffffffffa002e365>] drm_ioctl+0x125/0x610 [drm]
Dec 19 22:00:05 localhost kernel: [<ffffffff81101bcd>] ? call_rcu_sched+0x1d/0x20
Dec 19 22:00:05 localhost kernel: [<ffffffffa003d430>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
Dec 19 22:00:05 localhost kernel: [<ffffffff81234fb5>] ? __dentry_kill+0x145/0x1c0
Dec 19 22:00:05 localhost kernel: [<ffffffff81231445>] do_vfs_ioctl+0x295/0x470
Dec 19 22:00:05 localhost kernel: [<ffffffff8123dbc4>] ? mntput+0x24/0x40
Dec 19 22:00:05 localhost kernel: [<ffffffff8121fe0a>] ? __fput+0x17a/0x1e0
Dec 19 22:00:05 localhost kernel: [<ffffffff81231699>] SyS_ioctl+0x79/0x90
Dec 19 22:00:05 localhost kernel: [<ffffffff817795ae>] entry_SYSCALL_64_fastpath+0x12/0x71
Dec 19 22:00:05 localhost kernel: ---[ end trace 0ea58518f6abb5ce ]---
Dec 19 22:00:05 localhost kernel: ------------[ cut here ]------------


Expected results:

no kernel stack traces

Additional info:

the laptop has a Intel Sky Lake integrated graphics card.

VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07) (prog-if 00 [VGA controller])
Kernel driver in use: i915
Kernel modules: i915
Comment 1 Josh Boyer 2016-01-04 08:18:54 EST

*** This bug has been marked as a duplicate of bug 1293427 ***

Note You need to log in before you can comment on or make changes to this bug.