Bug 1293431 - Feature request Run As Root in right-click menu
Feature request Run As Root in right-click menu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 13:27 EST by M_M
Modified: 2015-12-22 12:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 09:41:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M_M 2015-12-21 13:27:02 EST
Description of problem:

It would be nice & more comfortable, whether the feature could appear.

It's quite disturbing to launch terminal and sudo-ing from there.

A little x-mas gift from Gnome $;)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Florian Müllner 2015-12-22 09:41:44 EST
(In reply to M_M from comment #0)
> It's quite disturbing to launch terminal and sudo-ing from there.

Fully-fledged GUI libraries like GTK+ or Qt (plus all their dependencies) are a huge attack vector, so running those with elevated privileges is disturbing[0]. We cannot force programs that require root privileges to use a saner approach like polkit, or users to not run graphical applications as root - however that does not mean that a convenient shoot-yourself-in-the-foot option is a good idea.

[0] http://www.gtk.org/setuid.html
Comment 2 M_M 2015-12-22 12:48:22 EST
(In reply to Florian Müllner from comment #1)
> (In reply to M_M from comment #0)
> > It's quite disturbing to launch terminal and sudo-ing from there.
> 
> Fully-fledged GUI libraries like GTK+ or Qt (plus all their dependencies)
> are a huge attack vector, so running those with elevated privileges is
> disturbing[0]. We cannot force programs that require root privileges to use
> a saner approach like polkit, or users to not run graphical applications as
> root - however that does not mean that a convenient
> shoot-yourself-in-the-foot option is a good idea.
> 
> [0] http://www.gtk.org/setuid.html

Whatever you call it - it is happening) A strange resistance to obvious... Should I, for e.g., turn off network to launch GParted or nautilus, or ... as root as they require to allow me on a regular basis management?

The better way it seems to be - "Run As" model - there are approaches when app needs to be run under certain user when logged in as root. One may brake one's fingers typing&retyping root's pwd whilst sudoing during debug testing of *nix .

There might be a compromise - as disabled by default but available option in Gnome preferences.

Note You need to log in before you can comment on or make changes to this bug.