Bug 1293456 - roles UI view shows duplicate permissions
roles UI view shows duplicate permissions
Status: CLOSED DUPLICATE of bug 1346296
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.1.5
All All
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 14:11 EST by Andrew Schofield
Modified: 2017-04-25 12:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-05 09:55:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Viewer Role (60.54 KB, image/png)
2015-12-21 14:11 EST, Andrew Schofield
no flags Details

  None (edit)
Description Andrew Schofield 2015-12-21 14:11:58 EST
Created attachment 1108449 [details]
Screenshot of Viewer Role

Description of problem:

In the WEB UI:

Administer -> Roles -> Filters

Shows a number of duplicated permissions for the 'Viewer' role.


Version-Release number of selected component (if applicable):

6.1.5

How reproducible:
Always, though only noticed on the 'Viewer' role.

Steps to Reproduce:
1. Go to Administer -> Roles
2. Next to the Viewer role, click 'Filters'
3. Notice the display say says 'Displaying entries 1 - 20 of 155 in total' across 8 pages.

Actual results:
Multiple, duplicated permissions displayed.

Expected results:
Should only display 1 entry for each permission.

Additional info:
Comment 5 Marek Hulan 2016-09-02 06:17:25 EDT
Andrew, the fact that role can have filters with the same permissions is not a bug. It's intended behavior, so you can have two filters with different search conditions. I remember there was an issue that some filters got duplicated on every installer run, see bz 1346296. I'd suggest either deleting all duplicated filters, if there are too many of them we could write a script that would deduplicate it. Please note that the duplicates will appear until Satellite is upgraded to 6.2. Would that be acceptable?
Comment 6 Marek Hulan 2016-09-05 09:55:26 EDT
And I also realized that just updating to to 6.2 will automatically remove duplicates. Therefore I'm closing this as duplicate too.

*** This bug has been marked as a duplicate of bug 1346296 ***

Note You need to log in before you can comment on or make changes to this bug.