Bug 1293608 - Shipping AppStream metadata file
Shipping AppStream metadata file
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pidgin-sipe (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Stefan Becker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 07:05 EST by Jiri Eischmann
Modified: 2016-01-01 11:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-01 11:31:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin-sipe-metainfo.xml (561 bytes, application/xml)
2015-12-22 07:05 EST, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2015-12-22 07:05:19 EST
Created attachment 1108623 [details]
pidgin-sipe-metainfo.xml

The package doesn't ship AppStream [1] metadata file, so it doesn't appear in Pidgin profile in the default app catalog GNOME Software and is not easily discoverable and installable for users.

I've already filed a bug upstream [2] because it should be ideally included there since it's used across Linux distributions, but unless/until upstream ships it it should be included downstream as the packaging guidelines say [3].

I've created the file for you, see the attachment.

[1] http://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Addons.html
[2] https://sourceforge.net/p/sipe/bugs/301/
[3] https://fedoraproject.org/wiki/Packaging:AppData
Comment 1 Stefan Becker 2016-01-01 11:31:30 EST
Implemented upstream by git commit http://repo.or.cz/siplcs.git/commitdiff/e045bc7dd4bf78445bf3e7c7c962683af4017478

Closing.

Note You need to log in before you can comment on or make changes to this bug.