Bug 1293656 - Evolution in RHEL 7 doesn't refresh correctly the next mail body when a mail in an *IMAP* folder is moved into another folder [NEEDINFO]
Evolution in RHEL 7 doesn't refresh correctly the next mail body when a mail ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.1
x86_64 Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Milan Crha
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 10:22 EST by Herve Lemaitre
Modified: 2017-03-09 12:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-09 12:58:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcrha: needinfo? (hlemaitr)


Attachments (Terms of Use)

  None (edit)
Description Herve Lemaitre 2015-12-22 10:22:18 EST
Description of problem:

My Inbox is an IMAP folder hosted in Zimbra Server.
I select a mail in the reader ; the subject is highlighted, and the body content is displayed below. 
When I move that mail into another folder (either local to my laptop or remote on imap), the mail is correctly moved, the reader correctly selects the next mail in the Inbox but doesn't refresh the body (which still shows the content of the moved mail).

This doesn't happen if I move a mail in a local folder. 



Version-Release number of selected component (if applicable):
RHEL 7.1
evolution 3.8.5 
evolution-help-3.8.5-31.el7.noarch
evolution-mapi-3.8.5-6.el7.x86_64
evolution-ews-3.8.5-8.el7.x86_64
evolution-3.8.5-31.el7.x86_64
evolution-data-server-3.8.5-34.el7.x86_64


How reproducible:

Always 


Steps to Reproduce:
1.- open evolution (3 window display, left frame contains folders, right  top frames contains mail headers, right low frame contains mail body)
2.- select a mail in an IMAP folder
3. - the header is selected,and body displayed. 
4. - move that mail into another folder
5. - the mail is moved, the selector highlights the next mail header in the top right frame, but the body low right frame is NOT refreshed, it still contains the body of the moved mail.

I need to re-click on the highlighted mail header to see the correct mail body displayed. 


Actual results:
Next mail body is not refreshed in the reading panel (low right). 

Expected results:
Next mail body should be displayed in the reading panel (low right frame)

Additional info:

My RHEL7 comes from within Red Hat internal IT (aka CSB)
Comment 2 Milan Crha 2016-01-11 07:51:01 EST
Thanks for a bug report. It will be good to update your CSB to RHEL 7.2, because it contains rebased version of the evolution-related packages to more recent version (3.12.11), which contains many fixes with compare of 3.8.5. I recall there used to be similar issues with the preview panel update, but I do not recall many details about it, only it didn't strike here as it could on other machines/for other users.

Could you retest with 3.12.11 and report back, please?
Comment 3 Milan Crha 2017-03-09 12:58:24 EST
I'm closing this for a lack of response. There is also a RHEL 7.4 undergo, which brings even newer evolution (it's more than a year, after all).
Comment 4 Red Hat Bugzilla Rules Engine 2017-03-09 12:58:31 EST
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.