Bug 1293664 - Request for pm-suspend-hybrid backport from RHEL 7 to RHEL 6.8
Request for pm-suspend-hybrid backport from RHEL 7 to RHEL 6.8
Status: CLOSED DUPLICATE of bug 870895
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pm-utils (Show other bugs)
6.8
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 10:46 EST by Lenny Szubowicz
Modified: 2015-12-22 11:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 11:03:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lenny Szubowicz 2015-12-22 10:46:12 EST
Description of problem:

RHEL 6.8 BZ 910715 against the kernel complains that pm-suspend-hybrid does not work in RHEL 6. 

In response to that BZ the kernel support via sysfs /sys/power/disk and /sys/power/state has been added.

However, even with the kernel support in place, the pm-suspend-hybrid command does not notice or utilize this support without a patch to the pm-functions shell script.

The relevant pm-utils patch from rhel-7.x is pm-utils-1.4.1-add-in-kernel-suspend-to-both.patch


Version-Release number of selected component (if applicable):

pm-utils-1.2.5-11


How reproducible:


Steps to Reproduce:
1. pm-suspend-hybrid


Actual results:

Using a test kernel with support for suspend hybrid.

[root@uefi09 ~]# uname -a
Linux uefi09.desklab.eng.bos.redhat.com 2.6.32-593.el6.bz0910715.lss01.x86_64 #1 SMP Mon Dec 21 13:15:36 EST 2015 x86_64 x86_64 x86_64 GNU/Linux

[root@uefi09 ~]# cat /sys/power/disk
[platform] test testproc shutdown reboot suspend 

Attempt to invoke pm-suspend-hybrid does nothing except return an error

[root@uefi09 ~]# pm-suspend-hybrid
[root@uefi09 ~]# echo $?
1

Expected results:

echo "suspend" > /sys/power/disk
echo "disk" > /sys/power/state
Comment 2 Lenny Szubowicz 2015-12-22 11:03:50 EST
Didn't notice that there was already a prior BZ for exactly this problem.

*** This bug has been marked as a duplicate of bug 870895 ***

Note You need to log in before you can comment on or make changes to this bug.