Bug 1293681 - Monodevelop crashes Gnome session
Monodevelop crashes Gnome session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 11:48 EST by Lukáš Kotek
Modified: 2015-12-24 11:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 11:04:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl log file (616.29 KB, text/x-vhdl)
2015-12-23 16:23 EST, Lukáš Kotek
no flags Details

  None (edit)
Description Lukáš Kotek 2015-12-22 11:48:11 EST
Description of problem:
Every time I try to open (or create) solution in Monodevelop I am logged out from Gnome session immediately.

Version-Release number of selected component (if applicable):
5.9.7-1

How reproducible:
Always

Steps to Reproduce:
1. Start Monodevelop
2. Open C# solution 

Actual results:
Crashes session

Expected results:
Wors normally

Additional info:
I had upgraded to F23 recently then I switched from copr mono repository (tpokorra/mono) to Fedora's default version.
Comment 1 Timotheus Pokorra 2015-12-23 10:05:09 EST
I have just tried it on my old Laptop 32 bit with Fedora 23 and MonoDevelop 5.9.7-1, and it works fine to open a simple solution in Gnome (not Gnome classic).

Can you please try to narrow the problem down even more?
When you create a new c# Console solution, don't add anything, save, close MonoDevelop, open MonoDevelop, open the solution again. That works for me.

Can you find anything in your log files?

Kicking you out of a Gnome session is pretty violent, there should be something in the logs?

What happens if you start MonoDevelop from a terminal? do you get any output there? (hopefully before you get kicked out of the Gnome session)
Comment 2 Lukáš Kotek 2015-12-23 16:23 EST
Created attachment 1109017 [details]
journalctl log file

Log file, relevant part starts at the time 16:27:13.
Comment 3 Lukáš Kotek 2015-12-23 16:40:26 EST
Thank you very much for your answer. And you're right I'll try to describe it comprehensively.

I reproduce this behavior every time I open MonoDevelop and try to open any solution (from recent solutions etc). The response (logging me out) is absolutely immediate. When I try to create new solution, it happens right after I click to "Create" in "Configure your new project dialog".

I attached the log file and there seems to be a relevant part at the time 16:27:13 with message: "Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1600003 (MonoDevelo)"  ...then the session is stopped.

I was thinking if there could be a relation to Unity 3D I experimented some time ago (older version of MonoDevelop is bundled), but I didn't find any connection.
http://blogs.unity3d.com/2015/08/26/unity-comes-to-linux-experimental-build-now-available/

(I also tried to run MonoDevelop from terminal as you suggested but there's no output.)
Comment 4 Lukáš Kotek 2015-12-24 11:04:58 EST
I tried to reproduce this behavior in the Boxes virtualized F23 with no luck. (Clean install solved it all.) This was definitely something related to my system only. I upgraded OS gradually from Fedora 20 to 23 and I also worked with many mono/monodevelop versions during the time. I think the reason was somewhere out there.

I'm sorry I didn't realize this sooner and for bothering you in this Christmas time :-( Thank for your concern!

Note You need to log in before you can comment on or make changes to this bug.