Bug 1293743 - [RFE] Satellite 5.7 installer check to make sure customer didn intend to upgrade to 5.6 instead, and upgrade RHEL OS as needed
[RFE] Satellite 5.7 installer check to make sure customer didn intend to upgr...
Status: VERIFIED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
570
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomáš Kašpárek
Radovan Drazny
: FutureFeature, UserExperience
Depends On:
Blocks: 260381 1291203
  Show dependency treegraph
 
Reported: 2015-12-22 17:42 EST by Xixi
Modified: 2017-01-12 08:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2015-12-22 17:42:55 EST
Description of problem:
Customer inadvertently upgrading to Satellite 5.7 when they meant to upgrade to 5.6: can upgrade check be added to make sure customer is not trying to upgrade to Satellite 5.7 schema in-place on RHEL 5 OS (since for Sat 5.7 would need migrate to RHEL 6)?

Version-Release number of selected component (if applicable):
Satellite 5.7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
customer ends up upgrading to 5.7 schema on RHEL 5 system and would need to restore and start-over often resulting in a sev1

Expected results:
have the installer detect if customer is trying to install or upgrade to Sat 5.7 on RHEL 5 OS (like running the schema upgrade script for 5.7), and point customer to OS upgrade steps

Additional info:
Comment 4 Radovan Drazny 2017-01-12 08:22:50 EST
Tested on RHEL5-Server-U11 with Satellite 5.6 installed. Installed the rhn-upgrade package, and then attempted an upgrade to Satellite-5.8-RHEL-6-20170111.1 x86_64.

# ./install.pl --skip-system-version-test --upgrade
* Starting Red Hat Satellite installer.
* Performing pre-install checks.
ERROR: Upgrade flag passed, but could not find the rhn-package in 5.8 version.
Please check version of installed rhn-upgrade package.

VERIFIED

Note You need to log in before you can comment on or make changes to this bug.