Bug 1293755 - Firefox 43 quits when attempting to display HTML 5 video
Firefox 43 quits when attempting to display HTML 5 video
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 21:30 EST by John Gotts
Modified: 2016-01-06 05:56 EST (History)
5 users (show)

See Also:
Fixed In Version: firefox-43.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 05:56:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Gotts 2015-12-22 21:30:03 EST
Description of problem:
The new Firefox 43 build that was released today crashes when trying to display HTML 5 video. The previous Firefox 42 build (as of yesterday) was fine.

Version-Release number of selected component (if applicable):
43.0-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. Go to https://www.google.com/?gws_rd=ssl#q=html+5+video+test
2. All links with HTML 5 video crash the browser

Actual results:
The browser crashes.

Expected results:
The browser should not crash and display HTML 5 video.

Additional info:
Not sure whether the problem is upstream or a problem with the build. If you go to the URL http://youtube.com/html5 you can see whether your browser is set up for HTML 5. Notably, mine is. Youtube does not crash the browser. It attempts to play HTML 5 video but then falls back to Flash.
Comment 1 John Gotts 2015-12-22 21:55:00 EST
This does appear to be a problem with the Fedora 22 build.

If you use Mozilla's x86_64 Firefox 43.0 build with the same profile, the following page not only loads but the bottom two videos play fine.

http://www.quirksmode.org/html5/tests/video.html

The H.264/MP4 video does not play for me but that is probably a separate issue.

Interestingly, Youtube HTML 5 playback with Firefox 43.0 appears to be broken for both builds.
Comment 2 John Gotts 2015-12-27 16:34:39 EST
Normally, if you go to the URL

https://www.youtube.com/html5

You want to have everything checked.

It looks like the regression with Firefox 43 was with the setting

MSE & H.264

In order to turn this specific setting off, you need to adjust the about:config setting

media.fragmented-mp4.enabled

and set it to false. With this setting disabled HTML5 video playback seems stable again.
Comment 3 Martin Stransky 2016-01-04 17:02:02 EST
Can you please test this package?

http://koji.fedoraproject.org/koji/buildinfo?buildID=708766
Comment 4 John Gotts 2016-01-04 17:41:10 EST
I have re-enabled

media.fragmented-mp4.enabled

and this new release looks good to me. No crashes.

Thanks for your hard work.

John
Comment 5 Martin Stransky 2016-01-06 05:56:38 EST
Okay, Thanks.

Note You need to log in before you can comment on or make changes to this bug.