Bug 1293824 - virt-who failed to communication with subscription manager as "BadStatusLine" when stop virt-who service
virt-who failed to communication with subscription manager as "BadStatusLine"...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Radek Novacek
gaoshang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 02:45 EST by Liushihui
Modified: 2016-11-30 19:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 02:14:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-12-23 02:45:00 EST
Description of problem:
When stop virt-who service,it will show ""Error in communication with subscription manager as BadStatusLine".

Version-Release number of selected component (if applicable):
virt-who-0.16-1.el6.noarch
subscription-manager-1.16.6-1.el6.x86_64
python-rhsm-1.16.4-1.el6.x86_64

How reproducible:
90%

Steps to Reproduce:
1. Register system to Satellite 
2. Configure virt-who run at libvirt mode and refresh interval is default.
3. Start virt-who service
[root@hp-z220-05 tmp]# service virt-who start
Starting virt-who: [  OK  ]
4. Stop virt-who service and check virt-who's log 
[root@hp-z220-05 tmp]# service virt-who stop
Stopping virt-who: [  OK  ]
[root@hp-z220-05 tmp]# ps -ef|grep virt-who
root     12326  9603  0 15:37 pts/0    00:00:00 grep virt-who
[root@hp-z220-05 tmp]# tail -f /var/log/rhsm/rhsm.log

Actual results:
Although virt-who was stop, virt-who will show communication error with subscription-manager in the log.
2015-12-23 15:37:11,114 [virtwho.main DEBUG] MainProcess(12294):MainThread @virtwho.py:terminate:413 - virt-who is shutting down
2015-12-23 15:37:12,119 [virtwho.main ERROR] MainProcess(12294):MainThread @virtwho.py:send:243 - Error in communication with subscription manager:
Traceback (most recent call last):
  File "/usr/share/virt-who/virtwho.py", line 222, in send
    self._sendGuestList(report)
  File "/usr/share/virt-who/virtwho.py", line 249, in _sendGuestList
    manager.sendVirtGuests(report.guests)
  File "/usr/share/virt-who/manager/subscriptionmanager/subscriptionmanager.py", line 140, in sendVirtGuests
    self.connection.updateConsumer(self.uuid(), guest_uuids=serialized_guests)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 943, in updateConsumer
    params['guestIds'] = self.sanitizeGuestIds(guest_uuids)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 987, in sanitizeGuestIds
    return [self.sanitizeGuestId(guestId) for guestId in guestIds or []]
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 993, in sanitizeGuestId
    if self.supports_resource('guestids'):
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 814, in supports_resource
    self._load_supported_resources()
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 801, in _load_supported_resources
    resources_list = self.conn.request_get("/")
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 654, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 551, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.6/httplib.py", line 1012, in getresponse
    response.begin()
  File "/usr/lib64/python2.6/httplib.py", line 404, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.6/httplib.py", line 368, in _read_status
    raise BadStatusLine(line)
BadStatusLine
2015-12-23 15:37:12,123 [virtwho.main DEBUG] MainProcess(12294):MainThread @virtwho.py:<module>:890 - virt-who terminated 

Expected results:
It shouldn't show any error info in the log when stop virt-who service.

Additional info:
Comment 1 Radek Novacek 2016-02-02 07:48:56 EST
I'm not able to reproduce this bug with latest testing version of virt-who. Can you please try to reproduce it?
Comment 2 Liushihui 2016-02-04 02:14:24 EST
It can't reproduce on the latest virt-who-0.16-3.el6.noarch. Therefore, close it as Worksforme.

Note You need to log in before you can comment on or make changes to this bug.