Bug 1293872 - SELinux policy doesn't work with versioned mediawiki paths
SELinux policy doesn't work with versioned mediawiki paths
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
low Severity low
: rc
: ---
Assigned To: Simon Sekidde
Jan Zarsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 05:28 EST by Patrick Uiterwijk
Modified: 2017-10-12 08:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-80.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-12 08:16:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Uiterwijk 2015-12-23 05:28:52 EST
Description of problem:
For EPEL, we have mediawiki in a versioned path (/var/www/mediawiki123, ...), but the policy only works if it's in /var/www/mediawiki/. Please update the policy to allow for versioned paths, since that's pretty much a requirement to be able to comply with EPEL packaging guidelines.
Comment 7 Lukas Vrabec 2017-10-12 08:16:56 EDT
We're going to close this bug as WONTFIX because

 * of limited capacity of selinux-policy developers
 * the bug is related to EPEL component or 3rd party SW only
 * the bug appears in unsupported configuration 

We believe this bug can be fixed via a local policy module.
For more information please see: 

 * https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/selinux_users_and_administrators_guide/sect-security-enhanced_linux-troubleshooting-fixing_problems#sect-Security-Enhanced_Linux-Fixing_Problems-Allowing_Access_audit2allow

If you disagree, please re-open the bug.
Comment 8 Lukas Vrabec 2017-10-12 08:20:20 EDT
We're going to close this bug as WONTFIX because

 * of limited capacity of selinux-policy developers
 * the bug is related to EPEL component or 3rd party SW only
 * the bug appears in unsupported configuration 

We believe this bug can be fixed via a local policy module.
For more information please see: 

 * https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/selinux_users_and_administrators_guide/sect-security-enhanced_linux-troubleshooting-fixing_problems#sect-Security-Enhanced_Linux-Fixing_Problems-Allowing_Access_audit2allow

If you disagree, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.