Bug 1293894 - oadm cannot create the server cert
oadm cannot create the server cert
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.1.0
All All
high Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 07:14 EST by zhaozhanqi
Modified: 2015-12-23 23:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-23 23:29:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2015-12-23 07:14:28 EST
Description of problem:
No files will be created when using 'oadm ca create-server-cert' 

Version-Release number of selected component (if applicable):
# oc version
oc v3.1.1.0
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:
always

Steps to Reproduce:
1. set up ose env 
2. Create server cert file
  
   $ CA=/etc/openshift/master
   $ oadm ca create-server-cert --signer-cert=$CA/ca.crt       --signer-key=$CA/ca.key --signer-serial=$CA/ca.serial.txt       --hostnames='*.cloudapps.example.com'       --cert=cloudapps.crt --key=cloudapps.key
3. ls -lrt

Actual results:
cloudapps.crt and cloudapps.key did not be created.

Expected results:
cloudapps.crt and cloudapps.key should be created.

Additional info:
the env is using container install mode
Comment 1 zhaozhanqi 2015-12-23 23:29:21 EST
Close this bug since the output file need the specified directory for container install, like use:
oadm ca create-server-cert --signer-cert=$CA/ca.crt       --signer-key=$CA/ca.key --signer-serial=$CA/ca.serial.txt       --hostnames='*.cloudapps.example.com'       --cert=/tmp/cloudapps.crt --key=/tmp/cloudapps.key

Note You need to log in before you can comment on or make changes to this bug.