Bug 1293937 - [SR-IOV] - VF that was attached to VM via HostDevices sub tab considered as free
[SR-IOV] - VF that was attached to VM via HostDevices sub tab considered as free
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.1.3
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Dan Kenigsberg
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 10:25 EST by Michael Burman
Modified: 2016-02-18 06:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:00:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51013 master MERGED engine: VfScheduler should consider directly attached VFs as non-free 2015-12-30 04:54 EST
oVirt gerrit 51182 ovirt-engine-3.6 MERGED engine: VfScheduler should consider directly attached VFs as non-free 2016-01-04 04:42 EST
oVirt gerrit 51223 ovirt-engine-3.6.2 MERGED engine: VfScheduler should consider directly attached VFs as non-free 2016-01-04 05:15 EST

  None (edit)
Description Michael Burman 2015-12-23 10:25:33 EST
Description of problem:
[SR-IOV] - VF that was attached to VM via HostDevices sub tab considered as free and can cause sometimes to other VM to fail running if it trying to run with a passthrough vNIC, because it tries to use the directly attached VF.

Version-Release number of selected component (if applicable):
3.6.2

How reproducible:
Sometimes 

Steps to Reproduce:
1. Enable few VFs on capable sr-iov host 
2. Attach 1 VF directly to a VM via HostDevices sub tab
3. Run VM
4. Add vNIC with passthrough profile to other VM and try to run it 

Actual results:
Sometimes VM failing to run, because the directly attached VF considered as free

Expected results:
VF that was attached directly to VM via HostDevices sub tab should be considered 
as non-free
Comment 1 Michael Burman 2016-01-17 04:31:45 EST
Verified on - 3.6.2.5-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.