Bug 1294001 - OSError: [Errno 30] Read-only file system: '/mnt/sysimage/etc/default/grub'
OSError: [Errno 30] Read-only file system: '/mnt/sysimage/etc/default/grub'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3a0301c302586c8cefea765c234...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 20:17 EST by Comlan QUENUM
Modified: 2015-12-31 09:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-31 09:43:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (3.32 MB, text/plain)
2015-12-23 20:18 EST, Comlan QUENUM
no flags Details
File: anaconda.log (58.29 KB, text/plain)
2015-12-23 20:18 EST, Comlan QUENUM
no flags Details
File: environ (537 bytes, text/plain)
2015-12-23 20:18 EST, Comlan QUENUM
no flags Details
File: journalctl (2.60 MB, text/plain)
2015-12-23 20:19 EST, Comlan QUENUM
no flags Details
File: lsblk_output (4.27 KB, text/plain)
2015-12-23 20:19 EST, Comlan QUENUM
no flags Details
File: nmcli_dev_list (2.56 KB, text/plain)
2015-12-23 20:19 EST, Comlan QUENUM
no flags Details
File: os_info (518 bytes, text/plain)
2015-12-23 20:19 EST, Comlan QUENUM
no flags Details
File: program.log (149.46 KB, text/plain)
2015-12-23 20:19 EST, Comlan QUENUM
no flags Details
File: storage.log (414.98 KB, text/plain)
2015-12-23 20:20 EST, Comlan QUENUM
no flags Details
File: ifcfg.log (4.39 KB, text/plain)
2015-12-23 20:20 EST, Comlan QUENUM
no flags Details
File: packaging.log (133 bytes, text/plain)
2015-12-23 20:20 EST, Comlan QUENUM
no flags Details

  None (edit)
Description Comlan QUENUM 2015-12-23 20:17:50 EST
Description of problem:
Hi,

I was trying to install the Linux release of Fedora, in order to replace my old Linux mint;

Each time I start the installation it crashes and stoppes when installing boot loader;

Even when I try to reinstall Linux Ubuntu or Linux Mint, the issue is the same; 
So many many days ago I am not able to to make my computer run again !

Some advises on some Linux blogs guess the problem could deal with hard disk curruption, but I tried "badblocks" and "e2fsck" commands but the issue is the same.

So the problem deals with new Fedora Linux intallation in order to replace Linux Mint.

Can you please help me ?

Sorry if my English is bad, I usually speak French.

Best Regards.

Comlan QUENUM

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1286, in eintr_retry_call
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1322, in open
    return eintr_retry_call(_open, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/bootloader.py", line 1490, in write_defaults
    defaults = open(defaults_file, "w+")
  File "/usr/lib64/python3.4/site-packages/pyanaconda/bootloader.py", line 1553, in write_config
    self.write_defaults()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/bootloader.py", line 1626, in write
    self.write_config()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/bootloader.py", line 2375, in writeBootLoaderFinal
    storage.bootloader.write()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/bootloader.py", line 2453, in writeBootLoader
    writeBootLoaderFinal(storage, payload, instClass, ksdata)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 240, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 30] Read-only file system: '/mnt/sysimage/etc/default/grub'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Comlan QUENUM 2015-12-23 20:18:53 EST
Created attachment 1109053 [details]
File: anaconda-tb
Comment 2 Comlan QUENUM 2015-12-23 20:18:56 EST
Created attachment 1109054 [details]
File: anaconda.log
Comment 3 Comlan QUENUM 2015-12-23 20:18:57 EST
Created attachment 1109055 [details]
File: environ
Comment 4 Comlan QUENUM 2015-12-23 20:19:45 EST
Created attachment 1109056 [details]
File: journalctl
Comment 5 Comlan QUENUM 2015-12-23 20:19:47 EST
Created attachment 1109057 [details]
File: lsblk_output
Comment 6 Comlan QUENUM 2015-12-23 20:19:48 EST
Created attachment 1109058 [details]
File: nmcli_dev_list
Comment 7 Comlan QUENUM 2015-12-23 20:19:49 EST
Created attachment 1109059 [details]
File: os_info
Comment 8 Comlan QUENUM 2015-12-23 20:19:53 EST
Created attachment 1109060 [details]
File: program.log
Comment 9 Comlan QUENUM 2015-12-23 20:20:02 EST
Created attachment 1109061 [details]
File: storage.log
Comment 10 Comlan QUENUM 2015-12-23 20:20:04 EST
Created attachment 1109062 [details]
File: ifcfg.log
Comment 11 Comlan QUENUM 2015-12-23 20:20:05 EST
Created attachment 1109063 [details]
File: packaging.log

Note You need to log in before you can comment on or make changes to this bug.