Bug 129404 - AGP 4x on a VT82C598/694x [Apollo MVP3/Pro133x AGP] not working
AGP 4x on a VT82C598/694x [Apollo MVP3/Pro133x AGP] not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-07 22:03 EDT by Th0ma7
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 22:57:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Th0ma7 2004-08-07 22:03:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I'm trying to make a GeForce FX 5900 working in AGP 4x rate on my asus
CUV4x-D motherboard (dual 1ghz).

I've made a lot of testing and I've never been able to make agpgart
working in 4x rate.  The only result I could get is 2x rate with
built-in kernels.

During my testing I've also tried to compile a new kernel
(2.6.8-rc3-bk2) and made sure agpgart was built-in but via-agp was a
module.  Doing so allowed me to add "alias agpgart via-agp" in my
modprobe.conf file to load via-agp has a module.  I was then capable
to switch between nvagp and agpgart easily.

After tweeking my nvidia drivers by adding the option to set the AGP
rate (NVreg_ReqAGPRate in os-registry.c of nvidia extracted 6106
drivers) I was capable to add in my modprobe.conf file:
options nvidia NVreg_EnableAGPSBA=1
options nvidia NVreg_EnableVia4x=0 or 1
options nvidia NVreg_ReqAGPRate=1 to 7
and switch between nvagp and agpgart with 'Option "NvAGP" "1, 2 or 3"'
in my xorg.conf file.

The option EnableVia4x did not made any change at all during all of my
testing.  But the option of AGPRate allowed me to get curious results:

If I choose agpgart (NvAGP set to either 2 or 3) and I set the AGPRate
to 0 to 3 (which I think in binary would be 000 to 011 meaning only
agp 1x and 2x allowed) the driver via-agp detects my host-bridge
correctly (for the first time!!!):
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge:     PCI device 1106:0691
Fast Writes:     Not Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000207:0x00000302

But, like I think it should, it sets the rate to either 1x or 2x.

If I try to set the AGPRate between 4 and 7 it gets weird, it does not
detect 4x rate at all:
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge:     PCI device 1106:0691
Fast Writes:     Not Supported
SBA:             Supported
AGP Rates:       2x 1x
Registers:       0x1f000207:0x00000302

And I simply get stuck in 1x rate at 4 and 5 and a 2x rate at 6 and 7.

When I try to load nvagp I always get stuck with a 2x rate unless I
set 1 or 5 has AGPRate option.

The only time I was capable to get a 4x rate was by setting agpgart
has the default driver and setting the AGPRate option to 1, 2 or 3 and
removing "alias agpgart via-agp" of my modprobe.conf file.  At the
next reboot my X started with no AGP support since no drivers where
specified to agpgart.  I've then switched to run-level 4, did a
"modprobe via-agp" and started an X.  At this particular moment agp 4x
gets detected but it gets set to 2x.  Then, after killing my X,
setting nvagp has the default driver, unloading via-agp and nvidia
drivers using rmmod then restarting an X... and then bang! nvagp,
maybie using the pre-detected agp rates, is finally capable to run in
4x mode!

But hey, I don't what to do this every time I try to make Doom 3
running :)

By the way, in my dmesg agpgart seems to detect the same host-bridge 4
times?  Here is the output:
Linux agpgart interface v0.100 (c) Dave Jones
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6106  Wed Jun
23 08:14:01 PDT 2004
agpgart: Detected VIA Apollo Pro 133 chipset
agpgart: Maximum main memory to use for agp memory: 1430M
agpgart: AGP aperture is 256M @ 0xe0000000
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode

Any any help would really really be appreciated!

Note: I've also tried to set AGP drive strength in my BIOS between
default and FF... bu tit mad no chage.  And by the way AGP is set to
4x in my BIOS.

thnx!

- vin

Version-Release number of selected component (if applicable):
kernel-2.6.All

How reproducible:
Always

Steps to Reproduce:
1. Boot using default kernel
2. Or boot using an hacked kernel with via-agp built has a module
3.
    

Additional info:
Comment 1 Th0ma7 2004-08-09 22:56:18 EDT
I'm closing this bug.. since the problem was occuring with nvidia 6106
drivers... and it has been fixed with 6111... I'm now capable of
having 4x with agpgart and nvagp..

thnx

- vin

Note You need to log in before you can comment on or make changes to this bug.