This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 129408 - iproute2's traffic control (tc) does not work properly when trying to add a u32 match rule
iproute2's traffic control (tc) does not work properly when trying to add a u...
Status: CLOSED DUPLICATE of bug 129397
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 06:02 EDT by Ventsislav Genchev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ventsislav Genchev 2004-08-08 06:02:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The problem obviiusly started to appear after i have installed
kernel-2.6.7-1.494.2.2.
The shaper stopped working, and after some investigations I found that
during the initial process of the cbq class files viq cbq.init, the
following message appears in /var/log/messages:

kernel: Please upgrade your iproute2 tools or compile proper options in!

And that was pretty od... I've tried to add the desired rules manually
and when reached the following line:

/sbin/tc filter add dev eth1 parent 1:0 protocol ip prio 100 u32 match
ip dst 192.168.31.10 classid 1:1001

it crashed with the following message:
RTNETLINK answers: Invalid argument

Hopefully I kept the old kernel and tested the same situation... there
was no problem... 

Don't know if this is a kernel bug really, or the iproute2 package
should be updated... don't know... For me.. the problem was solved
when i started the machine with the previous kernel version...


Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. Load with kernel-2.6.7-1.494.2.2
2. try to start some cbq shaper
3.
    

Actual Results:  the shaper does not work... 
/sbin/tc filter add dev eth1 parent 1:0 protocol ip prio 100 u32 match
ip dst 192.168.31.10 classid 1:1001
does not load... 

PS: yes... I've got all the needed modules loaded.. and yes.. I have
parent class 1001.. that ain't the problem

Expected Results:  the line above should be started with no error
messages and the shaper should work properly.

Additional info:
Comment 1 Marco Varanda 2004-08-09 16:35:20 EDT
Same as #129397 
Comment 2 Ventsislav Genchev 2004-08-10 04:06:07 EDT

*** This bug has been marked as a duplicate of 129397 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.