Bug 129416 - Can't remote login
Can't remote login
Status: CLOSED DUPLICATE of bug 128154
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 13:20 EDT by H.J. Lu
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2004-08-08 13:20:16 EDT
After running RHEL 4 alpha 4 for a few days with many
rlogin/ssh sessions into the machine, I got

[hjl@gnu hjl]$ ssh gnu-10
hjl@gnu-10's password:
Warning: Remote host failed or refused to allocate a pseudo tty.


It happens on both ia32 and EM64T.
Comment 1 H.J. Lu 2004-08-09 10:50:15 EDT
It looks like a glibc bug. I got

Aug  9 07:46:57 gnu-10 sshd[3684]: error: openpty: No such file or
directory
Aug  9 07:46:57 gnu-10 sshd[3684]: error: session_pty_req: session 0
alloc failed
Comment 2 H.J. Lu 2004-08-09 11:10:28 EDT
It looks like a kernel bug:

[pid  5879] open("/dev/ptmx", O_RDWR)   = -1 EIO (Input/output error)
[pid  5879] open("/dev/ptyp0", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp1", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp2", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp3", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp4", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp5", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp6", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp7", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp8", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptyp9", O_RDWR)  = -1 ENXIO (No such device or
address)
[pid  5879] open("/dev/ptypa", O_RDWR)  = -1 ENXIO (No such device or
address)

I saw it on 2.6.7-1.509 and 2.6.7-1.501.
Comment 3 Arjan van de Ven 2004-08-09 11:13:23 EDT
[pid  5879] open("/dev/ptmx", O_RDWR)   = -1 EIO (Input/output error)

that leass you to think it's a kernel bug

well... maybe maybe not I'm not convinced yet
Comment 4 Arjan van de Ven 2004-08-09 11:13:50 EDT
bug 128154 has a more detailed analysis fwiw
Comment 5 H.J. Lu 2004-08-09 11:30:57 EDT

*** This bug has been marked as a duplicate of 128154 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.