Bug 1294201 - Ship version using ILP64 BLAS
Ship version using ILP64 BLAS
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: arpack (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
https://github.com/opencollab/arpack-...
:
Depends On: 1352248
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 06:04 EST by Milan Bouchet-Valat
Modified: 2017-09-08 11:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.5.0-2.fc27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-08 11:27:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2015-12-25 06:04:01 EST
It is becoming more and more common to encounter very large sparse matrices whose dimensions can exceed the maximum value fitting in a 32-bit integer. For this reason, some projects have switched to an ILP64 BLAS. OpenBLAS in Fedora has shipped it for some time (Bug 1088256), and has just started shipping an alternative ILP64 version with all symbols suffixed with "64_" in order to allow a process to also load libraries built against an LP64 BLAS without conflicts (Bug 1287541).

As I've just switched my Julia package to the ILP64 OpenBLAS, I'd like to be able to use an ARPACK version based on ILP64 OpenBLAS too. Would you be willing to create an alternative version of ARPACK packages for that? Julia uses the following Makefile instructions to use the "64_"-suffixed functions):

ARPACK_OPENBLASFCNS1 := axpy copy gemv geqr2 lacpy lahqr lanhs larnv lartg lascl laset scal trevc trmm trsen gbmv gbtrf gbtrs gttrf gttrs pttrf pttrs
ARPACK_OPENBLASFCNS2 := dot ger labad laev2 lamch lanst lanv2 lapy2 larf larfg lasr nrm2 orm2r rot steqr swap
ARPACK_OPENBLASFCNS3 := dotc geru unm2r
ARPACK_OPENBLASFCNS4 := COPY LABAD LAMCH LANHS LANV2 LARFG ROT GEMV
ARPACK_FFLAGS += $(foreach fcn, $(ARPACK_OPENBLASFCNS1) $(ARPACK_OPENBLASFCNS2), -Ds$(fcn)=s$(fcn)_64 -Dd$(fcn)=d$(fcn)_64)
ARPACK_FFLAGS += $(foreach fcn, $(ARPACK_OPENBLASFCNS1) $(ARPACK_OPENBLASFCNS3), -Dc$(fcn)=c$(fcn)_64 -Dz$(fcn)=z$(fcn)_64)
ARPACK_FFLAGS += $(foreach fcn, $(ARPACK_OPENBLASFCNS4), -DS$(fcn)=S$(fcn)_64 -DD$(fcn)=D$(fcn)_64)
ARPACK_FFLAGS += -Dscnrm2=scnrm2_64 -Ddznrm2=dznrm2_64 -Dcsscal=csscal_64 -Dzdscal=zdscal_64
ARPACK_CFLAGS += -Dsgemm_=sgemm_64_ -Dcheev_=cheev_64_
Comment 1 Milan Bouchet-Valat 2016-01-06 05:47:33 EST
Filed an upstream bug at https://github.com/opencollab/arpack-ng/issues/30 (I hadn't realized Fedora was using ARPACK-ng, which is actively maintained).
Comment 2 Dominik 'Rathann' Mierzejewski 2016-01-06 18:04:17 EST
Thanks a lot for following up with upstream. I'll be happy to make the change in Fedora package once it's done upstream.
Comment 3 Jan Kurik 2016-02-24 09:10:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Dominik 'Rathann' Mierzejewski 2016-07-19 16:41:56 EDT
It looks like this is included in 3.4.0.
Comment 5 Dominik 'Rathann' Mierzejewski 2017-07-03 19:34:03 EDT
Working on this, should be ready soon.
Comment 6 Dominik 'Rathann' Mierzejewski 2017-07-03 20:30:58 EDT
This is now built in rawhide (3.5.0-2.fc27). Please test.
Comment 7 Dominik 'Rathann' Mierzejewski 2017-07-14 07:24:53 EDT
Milan, are the changes I made in the rawhide branch correct? I based them on your comment in the upstream ticket (https://github.com/opencollab/arpack-ng/issues/30#issuecomment-172192749). Shall I backport them to F26?
Comment 8 Milan Bouchet-Valat 2017-07-24 14:00:07 EDT
Sorry, I haven't had the time to tests this yet. I'll try to do that in the next few weeks. I don't think it needs to be backported to F26, anyway I won't take the risk of backporting these changes to Julia. But much thanks for doing this!
Comment 9 Dominik 'Rathann' Mierzejewski 2017-07-24 17:46:10 EDT
Ok, thanks for the response. I'll keep this rawhide-only. Let me know when you have the test results.
Comment 10 Jan Kurik 2017-08-15 04:57:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 11 Dominik 'Rathann' Mierzejewski 2017-09-08 11:27:26 EDT
I'll close this for now. Please open a new bug if the current implementation needs adjustment.

Note You need to log in before you can comment on or make changes to this bug.