Bug 1294217 - Background ignores stored orientation of images (layout is always put to landscape, even if image gets shown as portrait in an image viewer application)
Background ignores stored orientation of images (layout is always put to land...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
https://github.com/linuxmint/Cinnamon...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 08:41 EST by Raphael Groner
Modified: 2017-01-17 15:20 EST (History)
6 users (show)

See Also:
Fixed In Version: cinnamon-3.2.8-1.fc25 cinnamon-3.2.8-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-17 14:51:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample (1.26 MB, image/jpeg)
2016-02-29 15:11 EST, Raphael Groner
no flags Details

  None (edit)
Description Raphael Groner 2015-12-25 08:41:50 EST
Description of problem:
The background dialog shows all images in landscape mode, even if some of them are stored as portrait.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
yes

Steps to Reproduce:
1. login to cinnamon session
2. open background settings
3. look for orientation option

Actual results:
not possible to switch between portrait and landscape orientation

Expected results:
images show in preferred orientation mode (portrait|landscape), either choosable in settings dialog or directly read from image file

Additional info:
Not sure which concrete component to blame. As a start, I report against cinnamon cause it seems to be the most general.
Comment 1 Raphael Groner 2016-02-11 07:35:33 EST
Hmm, I can not reproduce in Fedora 23 with cinnamon 2.8.6 packages.

Leigh, could you try to reproduce in Fedora 22?
Comment 2 Fedora Blocker Bugs Application 2016-02-27 14:45:59 EST
Proposed as a Blocker and Freeze Exception for 24-beta by Fedora user raphgro using the blocker tracking app because:

 Not sure if it's a blocker. This bug breaks good user experience with wrongly orientated background pictures.
Comment 3 Andre Robatino 2016-02-27 14:51:54 EST
While subscribing to this bug, would like to mention that to be a Blocker or FE for 24, a problem has to actually exist on 24, not just on earlier versions. This is the second proposed bug by the same person where it's not clear if the bug even exists on 24. If it does, the Version should probably be bumped to 24.
Comment 4 Raphael Groner 2016-02-27 16:24:49 EST
(In reply to Andre Robatino from comment #3)
> While subscribing to this bug, would like to mention that to be a Blocker or
> FE for 24, a problem has to actually exist on 24, not just on earlier
> versions. This is the second proposed bug by the same person where it's not
> clear if the bug even exists on 24. If it does, the Version should probably
> be bumped to 24.

Currently, there's no option for me to do valueable usability tests with f24 because we have no working images to do any quick install with. So I just guessing this bug also exists in rawhide and f24 cause all cinnamon packages keep the same version 2.8.6. This bug is reproducible for sure in f22 and f23.
Comment 5 Raphael Groner 2016-02-27 16:26:02 EST
(In reply to Raphael Groner from comment #1)
> Hmm, I can not reproduce in Fedora 23 with cinnamon 2.8.6 packages.

That's not completely correct. It seems to depend on the individual image contents, no further investigation so far available.
Comment 6 Stephen Gallagher 2016-02-29 10:50:55 EST
Cinnamon is not a blocking desktop, so even if this issue is present, it's not worth blocking the release over.

I can't make the blocker review meeting today, so I'm voting -1 blocker here.
Comment 7 Petr Schindler 2016-02-29 13:45:20 EST
Discussed at 2016-02-29 blocker review meeting: [1]. 

This bug was rejected as Beta blocker: this is a Cinnamon bug, and Cinnamon is not a release blocking desktop.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-29/f24-blocker-review.2016-02-29-17.00.html
Comment 8 Raphael Groner 2016-02-29 15:11 EST
Created attachment 1131686 [details]
sample
Comment 9 leigh scott 2016-02-29 16:40:49 EST
This is a upstream issue please report it there instead.
Comment 10 Raphael Groner 2016-03-01 03:19:48 EST
Please keep this bug open till it's fixed downstream.
Comment 11 Raphael Groner 2016-03-29 02:19:20 EDT
No answer from upstream till now. As there's no good workaround available (yet), I want to cancel the proposal for a freeze exception (and of course no blocker).

Hint: An user can change internally stored orientation of picture with help from the context menu in cinnamon nemo (file manager) to get a dialog with some functionality.

Although, I insist this continues to be a nasty bug for normal users.
Comment 12 Raphael Groner 2016-03-31 04:37:08 EDT
(In reply to Raphael Groner from comment #11)
…
> Hint: An user can change internally stored orientation of picture with help
> from the context menu in cinnamon nemo (file manager) to get a dialog with
> some functionality.
…

# dnf install nemo-image-converter
Comment 13 Jan Kurik 2016-07-26 00:32:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 14 Fedora Update System 2017-01-08 07:23:58 EST
cinnamon-3.2.8-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c7360d603c
Comment 15 Fedora Update System 2017-01-08 07:24:26 EST
cinnamon-3.2.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-47e7f978bf
Comment 16 Fedora Update System 2017-01-08 21:22:07 EST
cinnamon-3.2.8-1.fc24, cinnamon-screensaver-3.2.13-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-47e7f978bf
Comment 17 Fedora Update System 2017-01-08 21:24:52 EST
cinnamon-3.2.8-1.fc25, cinnamon-screensaver-3.2.13-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c7360d603c
Comment 18 Fedora Update System 2017-01-17 14:51:10 EST
cinnamon-3.2.8-1.fc25, cinnamon-screensaver-3.2.13-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2017-01-17 15:20:02 EST
cinnamon-3.2.8-1.fc24, cinnamon-screensaver-3.2.13-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.