Bug 1294312 - VM Fullscreen mode is broken
VM Fullscreen mode is broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-26 14:48 EST by Roger Odle
Modified: 2016-01-11 15:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 15:14:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of packages installed related to libvirt, kvm, qemu, spice and uname report (3.39 KB, text/plain)
2015-12-26 14:48 EST, Roger Odle
no flags Details
Screen shot before first time fullscreen activated (1.41 MB, image/png)
2015-12-27 17:14 EST, Roger Odle
no flags Details
Screenshot shows window displacement when fullscreen turned off (2.05 MB, image/png)
2015-12-27 17:15 EST, Roger Odle
no flags Details
virt-manager-1.3.2 --debug output (14.18 KB, text/plain)
2015-12-31 01:28 EST, Roger Odle
no flags Details

  None (edit)
Description Roger Odle 2015-12-26 14:48:01 EST
Created attachment 1109719 [details]
List of packages installed related to libvirt, kvm, qemu, spice and uname report

Description of problem:
Fullscreen operation does not work properly for VM opened from VirtualManager. Window decoration disappears but window contents remain in the same place on the monitor.  The white bar for the return to normal mode may or may not be accessible.

I noticed that the first time I opened the VM window, it works correctly.  If I turn off full screen mode to return to the Fedora host and then try to reactivate fullscreen mode for the VM, it fails.  I have WindowsXP 32, Windows 7 64, Fedora 20 32-bit and Fedora 22 32-bit guests.  The behavior is the same for all guests regardless of guest os.

The scale option is set to rescale to the window size.

Version-Release number of selected component (if applicable):

virt-viewer.x86_64               3.0-1.fc23

How reproducible:

Everytime now.  It may have gotten worse.

Steps to Reproduce:
1. Open VM window from VirtualManager.  Select FullScreen from drop down menu. VM goes to full screen mode and operates correctly.
2. Turn off fullscreen mode and return to windowed mode.  Switch to any other Fedora window or open file browser. Just do anything else in the Fedora host.
3. Return to the VM window and select fullscreen mode again.

Actual results:

The guest video mode does change.  The window decorations disappear as expected for fullscreen mode.  The window contents remain in the same position.  They do not relocate to the fullscreen position.  The white bar for selecting return to normal mode is not found at the top of the screen as expected but it found at the center of the top where the VM window was before fullscreen mode was activated or it may not be accessible at all.

If the white bar is accessible, the VM may be returned to windowed mode where is appears to operate correctly.

If the VM window is closed completely and reopened with the VirtualManager, the VM window and go to full screen mode properly one like it did before.  If you toggle the fullscreen mode then this same behavior happens.

Expected results:

Fullscreen mode should work correctly everytime, not just the first time.

Additional info:

This behavior started within the last two months under FC22 before I upgraded to FC23.
Comment 1 Pavel Grunt 2015-12-27 09:54:01 EST
virt-manager or virt-viewer ?
Comment 2 Roger Odle 2015-12-27 16:50:04 EST
I do not understand the question.  I launch VMs with virt-manager and open the windows to access the VMs virt-manager.  It is my understanding that virt-manager launches virt-viewer to visualize a spice-server session.  I do not run a separate application directly to operate VMs but try to perform all high-level tasks with virt-manager.
Comment 3 Roger Odle 2015-12-27 17:14 EST
Created attachment 1109887 [details]
Screen shot before first time fullscreen activated
Comment 4 Roger Odle 2015-12-27 17:15 EST
Created attachment 1109888 [details]
Screenshot shows window displacement when fullscreen turned off
Comment 5 Roger Odle 2015-12-27 17:16:30 EST
Screenshot 1 - first time before fullscreen.png

When opened first time, VM window fills desktop up to the top menu bar.

Screenshot 2 - after fullscreen turned off.png

1.  When fullscreen turned off, VM window is displaced from the original position, moving down and to the right as shown.

2.  Window title-bar disappears the second time fullscreen mode is turned on.

System Information

Host: HP Envy-17 Laptop
Arch: Intel i7-3610QM Ivybridge Mobile, 16 GB DRAM
Storage: dual drive bays with SSD + HD

VMs stored on HD
Comment 6 Fabiano Fidêncio 2015-12-27 19:31:43 EST
(In reply to Roger Odle from comment #2)
> I do not understand the question.  I launch VMs with virt-manager and open
> the windows to access the VMs virt-manager.  It is my understanding that
> virt-manager launches virt-viewer to visualize a spice-server session.  I do
> not run a separate application directly to operate VMs but try to perform
> all high-level tasks with virt-manager.

So, re-assigning the bug to virt-manager.
virt-viewer is a different app, used only as a viewer and not started from virt-manager.
Comment 7 Cole Robinson 2015-12-30 16:47:03 EST
Thanks for the report. A couple things to try:

- sudo yum --enablerepo=updates-testing update virt-manager    There's a new version, not sure if it will help though

- Eliminate some variables: Try to reproduce from a fresh machine restart, like with no VLC running (I see it in the screenshot).

- It looks like your VM resolution is large enough to extend across 2 monitors, that could be confusing gtk, try reducing the VM resolution to something smallish.

- Run virt-manager --debug from the command line and reproduce, capture the entire output and post it here. There may be stderr gtk messages
Comment 8 Roger Odle 2015-12-31 01:24:58 EST
I tried the new version installed with

sudo yum --enablerepo=updates-testing update virt-manager

This provides:
$ virt-manager --version
1.3.2

The windows no longer drops down to the right when fullscreen mode is turned off.  The window is now restored to the pre-fullscreen position and size.

If the window is maximized before fullscreen mode is activated, then it appears to work correctly.  I can toggle fullscreen mode on and off.

If the window is not maximized then it goes into fullscreen mode without relocating the window to the top-left corner of the screen.  It exhibits the behavior described before.

Workaround: double-click in the window title to maximize the VM window before activating fullscreen mode.  It works. If fullscreen mode is turned off again and the window is reduced then the failure happens again.  Maximize the window before activating fullscreen mode and it works again.  This if the behavior of the new release.  The previous release always shifted the window coordinates when fullscreen is turned off. I am attaching virt-manager log.

I have a laptop with a built-in 1920x1080 display and two HDMI 1920x1080 monitors connected.  The laptop display is turned off so it operates as a two display system.  The VM resolution is 1920x1080 so that it operates as the full-resolution of the monitors in fullscreen mode.  The snapshots show the combined desktop of two monitors (2*1920x1080).  The VM resolution is not large enough to span multiple monitors but the window does occupy two windows when it is shifted out of position.
Comment 9 Roger Odle 2015-12-31 01:28 EST
Created attachment 1110688 [details]
virt-manager-1.3.2 --debug output

Log file produced from virt-manager installed from testing-updates
Comment 10 Roger Odle 2015-12-31 12:03:07 EST
I repeated the tests described in Comment 8 after reboot the laptop.  The behavior is the same when virt-manager is the only application that is launched after startup.
Comment 11 Cole Robinson 2015-12-31 12:38:18 EST
I'm guessing this is some issue with gtk's fullscreening behavior, but I'll try and reproduce more before reassigning.

Roger, can you try and reproduce with the standalone virt-viewer client? From the command line run:

virt-viewer --connect qemu:///system YOUR-VM-NAME

then try and reproduce the issue with the same setup you described above
Comment 12 Roger Odle 2015-12-31 13:08:35 EST
I left a VM running that was started with virt-manager but I closed the virt-manager windows.

I opened the VM with

virt-viewer --connect qemu:///system winxp

virt-viewer works correctly.  I can toggle between fullscreen and windowed mode and it always works.  I did it at least 10 times and moved the window each time.  When fullscreen mode was turned off, the window always returned where it was before as expected.  I tried it with "window maximised" mode and with normal window mode.
Comment 13 Roger Odle 2016-01-10 21:05:59 EST
I have determined that it is something to do with the configuration of my user account.  F23 was installed as an upgrade to an F22 system so the configuration was carried over.  I removed the configuration and cache folders (.config, .cache, .gnome2, .gnome2-private) to make gnome create clean ones, it behaved properly.  This seems strange because there are not many configurable items in virt-manager and if the problem is in the cache then why wasn't that cleared during installation or first login after upgrade?  It is simple enough to record the OS version into the cache to determine when clearing is needed.
Comment 14 Cole Robinson 2016-01-11 15:14:12 EST
It might not be cache related, it could be some UI config setting that you set long ago that was tickling the issue. Maybe even a virt-manager specific setting that causes the problem.

Closing this for now since I can't reproduce, but if you end up reproducing in the future please reopen

Note You need to log in before you can comment on or make changes to this bug.