Bug 1294372 - Shipping AppStream metadata file
Shipping AppStream metadata file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: purple-line (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 14:43 EST by Jiri Eischmann
Modified: 2016-01-25 23:56 EST (History)
2 users (show)

See Also:
Fixed In Version: purple-line-20151114git26f6511-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 23:59:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin-line.metainfo.xml (554 bytes, application/xml)
2015-12-27 14:43 EST, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2015-12-27 14:43:25 EST
Created attachment 1109854 [details]
pidgin-line.metainfo.xml

The package doesn't ship AppStream [1] metadata file, so it doesn't appear in Pidgin profile in the default app catalog GNOME Software and is not easily discoverable and installable for users.

I've already filed a bug upstream [2] because it should be ideally included there since it's used across Linux distributions, but unless/until upstream ships it it should be included downstream as the packaging guidelines say [3].

I've created the file for you, see the attachment.

[1] http://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Addons.html
[2] http://altrepo.eu/git/purple-line/issues/23
[3] https://fedoraproject.org/wiki/Packaging:AppData
Comment 1 fujiwara 2016-01-04 04:52:59 EST
Probably I think updatecontact is myself and id is purple-line
Comment 2 fujiwara 2016-01-04 05:08:23 EST
And the file name is purple-line.metainfo.xml
Comment 3 fujiwara 2016-01-25 23:56:16 EST
Seems update_contact instead of updatecontact

Note You need to log in before you can comment on or make changes to this bug.