Bug 1294423 - reattaching fails after upgrade
reattaching fails after upgrade
Status: CLOSED DUPLICATE of bug 1271131
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: screen (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Hracek
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 02:46 EST by Yedidyah Bar David
Modified: 2016-01-04 04:47 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 04:47:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2015-12-28 02:46:17 EST
Description of problem:

If screen server is running, and package is upgraded, updated client can't reattach to running server.

Version-Release number of selected component (if applicable):

4.0.3-18.el6

How reproducible:

I think always

Steps to Reproduce:
1. Install screen-4.0.3-16.el6.x86_64
2. Run screen
3. Detach
4. Update to screen-4.0.3-18.el6.x86_64
5. screen -r -d

Actual results:

Gets stuck

Expected results:

Successfully reconnect, or at least give useful error message

Additional info:

I (naturally) did not know it was related to the upgrade. I searched for "screen reattach stuck" and found [1]. Following that, I downgraded to screen-4.0.3-16.el6.x86_64, and then managed to reattach.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683228
Comment 2 Petr Hracek 2016-01-04 04:47:19 EST

*** This bug has been marked as a duplicate of bug 1271131 ***

Note You need to log in before you can comment on or make changes to this bug.