Bug 1294445 - [RHEV-H] - Can't register rhev-h host via TUI to rhev-m engine if it's over bond interface. Host is not visible in rhev-m
[RHEV-H] - Can't register rhev-h host via TUI to rhev-m engine if it's over b...
Status: CLOSED DUPLICATE of bug 1207594
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.6
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Fabian Deutsch
wanghui
node
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 03:35 EST by Michael Burman
Modified: 2016-07-03 20:41 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 05:54:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs1 (10.68 KB, application/x-gzip)
2015-12-28 03:40 EST, Michael Burman
no flags Details
logs2 (9.51 KB, application/x-gzip)
2015-12-28 03:40 EST, Michael Burman
no flags Details
vdsm-reg log (58.27 KB, application/x-gzip)
2015-12-29 03:39 EST, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2015-12-28 03:35:21 EST
Description of problem:
Can't register rhev-h host via TUI to rhev-m engine if it's over bond interface. Host is not visible in rhev-m(3.5.7+3.6.z). 

If trying to register a rhev-h host to rhev-m engine via TUI and the interface that has IP is a bond, host is not visible in rhev-m UI. 
Once changing the interface to NIC, host become visible in rhev-m. 

Version-Release number of selected component (if applicable):
7.2 (20151129.1.el7ev)
vdsm-4.16.30-1.el7ev.x86_64
ovirt-node-3.2.3-29.el7.noarch

release 7.2 (20151218.1.el7ev)
vdsm-4.16.31-1.el7ev.x86_64
ovirt-node-3.2.3-30.el7.noarch

How reproducible:
100 with : 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151129.1.el7ev)
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151218.1.el7ev)


Steps to Reproduce:
1. Install clean rhev-h 7.2 20151129.1.el7ev/20151218.1.el7ev
2. Via TUI configure a bond interface with DHCP and get IP
3. Try to register host in rhev-m, 3.5.7 or 3.6

Actual results:
Host is not visible in rhev-m UI
In TUI everything seems to be fine. host managed by the rhev-m engine, networking is OK and connected via bond interface. 

Expected results:
Should work as expected. Host should be visible in UI once registered in TUI, no matter over which interface. bond or NIC. 

I think it's a regression bug..
Comment 1 Michael Burman 2015-12-28 03:40 EST
Created attachment 1109985 [details]
logs1
Comment 2 Michael Burman 2015-12-28 03:40 EST
Created attachment 1109986 [details]
logs2
Comment 4 Douglas Schilling Landgraf 2015-12-28 11:43:16 EST
(In reply to Michael Burman from comment #0)
> Description of problem:
> Can't register rhev-h host via TUI to rhev-m engine if it's over bond
> interface. Host is not visible in rhev-m(3.5.7+3.6.z). 
> 
> If trying to register a rhev-h host to rhev-m engine via TUI and the
> interface that has IP is a bond, host is not visible in rhev-m UI. 
> Once changing the interface to NIC, host become visible in rhev-m. 
> 
> Version-Release number of selected component (if applicable):
> 7.2 (20151129.1.el7ev)
> vdsm-4.16.30-1.el7ev.x86_64
> ovirt-node-3.2.3-29.el7.noarch
> 
> release 7.2 (20151218.1.el7ev)
> vdsm-4.16.31-1.el7ev.x86_64
> ovirt-node-3.2.3-30.el7.noarch
> 
> How reproducible:
> 100 with : 
> Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151129.1.el7ev)
> Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151218.1.el7ev)
> 
> 

Both ISOs are 3.5 version and registration is running with vdsm-reg. Could you please attach log-collector from host?
Comment 5 Michael Burman 2015-12-29 03:38:30 EST
Hi Douglas)

Yes, indeed both isos are 3.5 and in vdsm-reg.log i can see:

- For default rhev-h bond mode in 3.5 (balance-rr) -->

MainThread::DEBUG::2015-12-29 08:24:21,465::deployUtil::438::root::_getMGTIface: read host name: 10.35.161.55
MainThread::DEBUG::2015-12-29 08:24:21,465::deployUtil::446::root::_getMGTIface: using host name 10.35.161.55 strIP= 10.35.161.55
MainThread::DEBUG::2015-12-29 08:24:21,465::deployUtil::453::root::_getMGTIface IP=10.35.161.55 strIface=bond0
MainThread::DEBUG::2015-12-29 08:24:21,466::deployUtil::1059::root::makeBridge found the following bridge paramaters: ['BONDING_OPTS=mode=balance-rr miimon=100', 'BOOTPROTO=dhcp', 'IPV6INIT=no', 'IPV6_AUTOCONF=no', 'ONBOOT=yes', 'PEERNTP=yes']
MainThread::ERROR::2015-12-29 08:24:21,469::deployUtil::986::root::_getRHELBridgeParams Found bonding: bond0.This network configuration is notsupported! Please configure rhevm bridgemanually and re-install.
MainThread::ERROR::2015-12-29 08:24:21,470::deployUtil::1141::root::makeBridge errored:  out=
err=None
ret=None
MainThread::DEBUG::2015-12-29 08:24:21,470::deployUtil::1144::root::makeBridge return.
MainThread::ERROR::2015-12-29 08:24:21,470::vdsm-reg-setup::100::root::renameBridge Failed to rename existing bridge!
MainThread::DEBUG::2015-12-29 08:24:21,470::vdsm-reg-setup::126::root::renameBridge return.
MainThread::DEBUG::2015-12-29 08:24:21,470::vdsm-reg-setup::238::root::execute: after renameBridge: False
MainThread::DEBUG::2015-12-29 08:24:21,470::vdsm-reg-setup::316::root::Registration status: False

- For other bond mode, for example active-backup -->

MainThread::DEBUG::2015-12-29 07:52:21,217::deployUtil::438::root::_getMGTIface: read host name: 10.35.161.55
MainThread::DEBUG::2015-12-29 07:52:21,218::deployUtil::446::root::_getMGTIface: using host name 10.35.161.55 strIP= 10.35.161.55
MainThread::DEBUG::2015-12-29 07:52:21,218::deployUtil::453::root::_getMGTIface IP=10.35.161.55 strIface=bond0
MainThread::DEBUG::2015-12-29 07:52:21,218::deployUtil::1059::root::makeBridge found the following bridge paramaters: ['BONDING_OPTS=mode=active-backup miimon=100', 'BOOTPROTO=dhcp', 'IPV6INIT=no', 'IPV6_AUTOCONF=
no', 'ONBOOT=yes', 'PEERNTP=yes']
MainThread::ERROR::2015-12-29 07:52:21,222::deployUtil::986::root::_getRHELBridgeParams Found bonding: bond0.This network configuration is notsupported! Please configure rhevm bridgemanually and re-install.
MainThread::ERROR::2015-12-29 07:52:21,222::deployUtil::1141::root::makeBridge errored:  out=
err=None
ret=None
MainThread::DEBUG::2015-12-29 07:52:21,222::deployUtil::1144::root::makeBridge return.
MainThread::ERROR::2015-12-29 07:52:21,223::vdsm-reg-setup::100::root::renameBridge Failed to rename existing bridge!
MainThread::DEBUG::2015-12-29 07:52:21,223::vdsm-reg-setup::126::root::renameBridge return.
MainThread::DEBUG::2015-12-29 07:52:21,223::vdsm-reg-setup::238::root::execute: after renameBridge: False
MainThread::DEBUG::2015-12-29 07:52:21,223::vdsm-reg-setup::316::root::Registration status: False

- In both cases the bond0 is not supported.. 

- Attaching the vdsm-reg.log, 
please note, i have collected info from log-collector, but it have no info about this host, because it's in 'Registration status: False' ^^ and engine have no info about the server..so not sure how this can be helpful..if you still need logs from log-collector let me know and i will attach them.
Comment 6 Michael Burman 2015-12-29 03:39 EST
Created attachment 1110128 [details]
vdsm-reg log
Comment 7 Douglas Schilling Landgraf 2015-12-29 12:18:55 EST
Hi Michael,

In 3.5 the node uses vdsm-reg and TUI registration over bond is not supported as the error message says. 

:ERROR::2015-12-29 07:52:21,222::deployUtil::986::root::_getRHELBridgeParams Found bonding: bond0.This network configuration is notsupported! Please configure rhevm bridgemanually and re-install.

In rhev-h 3.6 we replaced the vdsm-reg and you can use TUI to create the bond and register the node. If there is no more concerns, I'd suggest remove the regression keyword and close this bug.
Comment 8 Michael Burman 2015-12-30 01:05:10 EST
Hi Douglas, what do you mean not supported? i know that you replaced the vdsm-reg on 3.6, but, 
It used to work in all previous 3.5.z versions.

Dan, is it make any sense?
Comment 9 Dan Kenigsberg 2015-12-30 05:54:55 EST
I fully trust Douglas (and Fabian, see https://bugzilla.redhat.com/show_bug.cgi?id=1207594#c2 ) on that.

Note again, that ovirt-3.6 can do that.

*** This bug has been marked as a duplicate of bug 1207594 ***
Comment 10 Fabian Deutsch 2016-01-04 05:56:57 EST
Michael, this is interesting that it worked in 3.5.z because we know that vdsm-reg has the limitations of not working correctly with bonds.

Are you sure that you were using the registration flow, and not the add-host flow?
Comment 11 cshao 2016-01-05 02:10:17 EST
Actually we have reported this bug before, see Bug 1097713 - Can't register rhevh to rhevm 3.4 when using bond as rhevh network. And the fixed Target Release is set to 3.6.

I have two advice:
1. move component to vdsm but not ovirt-node.
2. Dup this bug to 1097713 or 994451.

Thanks!
Comment 12 Michael Burman 2016-01-05 04:43:25 EST
Hi Fabian, i thought i was sure because i usually not using the 'add-host' flow with rhev-h servers and i'm testing 3.5.z quite a lot and for a long time now..usually using the registration flow..but you saying it never was supported on 3.5.z(vdsm-reg), so i don't know how sure i'm )

Note You need to log in before you can comment on or make changes to this bug.