Bug 1294586 - DHT:Rebalance is failing with failed to perform setattr
DHT:Rebalance is failing with failed to perform setattr
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
Anoop
dht-rca-unknown, dht-rebalance-file
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 00:41 EST by RajeshReddy
Modified: 2016-09-17 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-01 09:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rebalance_log (49.28 KB, text/plain)
2015-12-29 00:41 EST, RajeshReddy
no flags Details

  None (edit)
Description RajeshReddy 2015-12-29 00:41:01 EST
Created attachment 1110087 [details]
rebalance_log

Description of problem:
============
DHT:Rebalance is failing with failed to perform setattr 

Version-Release number of selected component (if applicable):
=================
glusterfs-server-3.7.5-13

How reproducible:


Steps to Reproduce:
============
1. Create a volume with one brick and mount it on client using FUSE and create few files of around 10GB and Crete large file using DD while writes are going on
2. Add another brick to the volume and remove the original brick from the volume and while files are migrating delete all files from the mount 


Actual results:
=============
Rebalance is failing with failed to perform setattr 


Expected results:


Additional info:
============

[root@rhs-client18 dht_rebal_delete_new]# gluster vol info dht_rebal_delete
 
Volume Name: dht_rebal_delete
Type: Distribute
Volume ID: ac8d73df-75d7-4370-9b61-a9f0e32b3341
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: rhs-client18.lab.eng.blr.redhat.com:/rhs/brick2/dht_rebal_delete_new
Options Reconfigured:
performance.readdir-ahead: on
Comment 2 Susant Kumar Palai 2016-07-01 09:10:19 EDT
(In reply to RajeshReddy from comment #0)
> Created attachment 1110087 [details]
> rebalance_log
> 
> Description of problem:
> ============
> DHT:Rebalance is failing with failed to perform setattr 
> 
> Version-Release number of selected component (if applicable):
> =================
> glusterfs-server-3.7.5-13
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> ============
> 1. Create a volume with one brick and mount it on client using FUSE and
> create few files of around 10GB and Crete large file using DD while writes
> are going on
> 2. Add another brick to the volume and remove the original brick from the
> volume and while files are migrating delete all files from the mount 
Since the files are getting deleted, setattr or any operation for that matter may fail on that file.
> 
> 
> Actual results:
> =============
> Rebalance is failing with failed to perform setattr 
> 
> 
> Expected results:
> 
> 
> Additional info:
> ============
> 
> [root@rhs-client18 dht_rebal_delete_new]# gluster vol info dht_rebal_delete
>  
> Volume Name: dht_rebal_delete
> Type: Distribute
> Volume ID: ac8d73df-75d7-4370-9b61-a9f0e32b3341
> Status: Started
> Number of Bricks: 1
> Transport-type: tcp
> Bricks:
> Brick1: rhs-client18.lab.eng.blr.redhat.com:/rhs/brick2/dht_rebal_delete_new
> Options Reconfigured:
> performance.readdir-ahead: on

Note You need to log in before you can comment on or make changes to this bug.