Bug 1294634 - texlive-pstricks should have a dependency on texlive-pst-tools
texlive-pstricks should have a dependency on texlive-pst-tools
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 06:42 EST by Henrique Ferreiro
Modified: 2016-01-23 22:32 EST (History)
9 users (show)

See Also:
Fixed In Version: texlive-2014-18.20140525_r34255.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1010920
Environment:
Last Closed: 2016-01-23 22:32:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrique Ferreiro 2015-12-29 06:42:28 EST
Still not fixed in Fedora 23.

+++ This bug was initially created as a clone of Bug #1010920 +++

Description of problem:

After upgrading from FC17 to FC19, I end up with an unusable dvips. It looks like the necessary texlive packages weren't installed. 

$ dvips file.dvi -o 
This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com)
' TeX output 2013.09.23:1511' -> paper.ps
dvips: ! Couldn't find header file: pst-tools.pro


Doing a 'yum groupinstall 'Authoring and Publishing' installs some packages, but it still doesn't solve the problem.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

See above.

Actual results:

See above.

Expected results:

The necessary should've been made part of 'Authoring and Publishing' group at the least, if not installed during the upgrade. 


Additional info:

--- Additional comment from Nineth on 2013-09-24 05:37:37 EDT ---

It turns out package texlive-pst-tools has it. It should be installed if texlive-pstricks was installed.

--- Additional comment from Alain Portal on 2013-12-14 09:35:53 EST ---

Thank for your bug report, it helped me to solve the same problem I got.

--- Additional comment from Nineth on 2014-05-19 02:46:56 EDT ---

I reported this for Fedora 19 and I still see the same problem with Fedora 20. Can the maintainer please fix this or respond?

--- Additional comment from Aidan Delaney on 2015-02-12 04:48:19 EST ---

I'm still seeing this dependency issue in Fedora 21.

--- Additional comment from Fedora End Of Life on 2015-05-29 05:26:30 EDT ---

This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

--- Additional comment from Fedora End Of Life on 2015-06-29 08:26:26 EDT ---

Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 1 Fedora Update System 2016-01-19 22:16:30 EST
texlive-2014-18.20140525_r34255.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-74f2c23353
Comment 2 Fedora Update System 2016-01-20 18:57:41 EST
texlive-2014-18.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-74f2c23353
Comment 3 Fedora Update System 2016-01-23 22:31:46 EST
texlive-2014-18.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.