Bug 1294665 - "Red Hat Documentation" tab gives 404 error
"Red Hat Documentation" tab gives 404 error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.3
: 3.6.3
Assigned To: Alexander Wels
Petr Matyáš
:
Depends On: 1298958
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 09:33 EST by Barak Korren
Modified: 2016-03-14 08:48 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 08:48:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error message (95.09 KB, image/png)
2015-12-29 09:33 EST, Barak Korren
no flags Details

  None (edit)
Description Barak Korren 2015-12-29 09:33:54 EST
Created attachment 1110242 [details]
screenshot of error message

Description of problem:
"Red Hat Documentation" tab in the admin UI gives out 404 error

Version-Release number of selected component (if applicable):
RHEV: 3.6.2-3
Engine: 3.6.2-0.1

Additional info:
Screen-shot attached
Comment 1 Yaniv Kaul 2015-12-30 04:27:47 EST
I assume rhevm-doc* packages are installed?
Comment 2 Barak Korren 2015-12-30 04:31:56 EST
(In reply to Yaniv Kaul from comment #1)
> I assume rhevm-doc* packages are installed?

Yep:

  # rpm -q rhevm-doc
  rhevm-doc-3.6.0-2.el6eng.noarch

Also the 'Guide' button in the upper-right corner works.
Comment 3 Alexander Wels 2016-01-13 13:23:41 EST
So did some research and it appears that the Virtual Machine section in the documentation is missing. Presumably because managing virtual machines is under its own book online. However the built version mentioned above does not contain this book. If for instance you go to 'hosts' select one and click the documentation tab, it does load properly.

Once we have a proper build that contains the new virtual machine book, I can adjust the links to point to it.
Comment 4 Einav Cohen 2016-01-18 07:05:05 EST
after discussing with Alexander and the docs team:

There are two broken "Red Hat Documentation" sub-tabs in RHEV at the moment: 
(1) in the VMs main tab
(2) in the Templates main tab

The current (broken) URL for (1) is:
.../html/Administration_Guide/chap-Virtual_Machines.html
It should be changed to:
.../html/Virtual_Machine_Management_Guide/chap-Installing_Linux_Virtual_Machines.html

[NOTE: As part of the restructure, content on installing virtual machines has been divided into two separate end-to-end installation chapters: 'Installing Linux Virtual Machines' and 'Installing Windows Virtual Machines'. the Red Hat Documentation sub-tab obviously expects one link per main UI tab, so we will provide the 'Linux' link above because it is the first of the two virtual machine installation chapters. Users can click through to the 'Windows' chapter if required, or view both chapters in the complete guide.]

The current (broken) URL for (2) is:
.../html/Administration_Guide/chap-Templates.html
It should be changed to:
.../html/Virtual_Machine_Management_Guide/chap-Templates.html

As both links are within the Virtual Machine Management Guide, this will require including the Virtual Machine Management Guide in the rhevm-doc package (tracked via blocking bug 1298958).
Comment 5 Einav Cohen 2016-01-18 08:47:39 EST
blocking bug 1298958 most likely not going to happen for 3.6.2, only for 3.6.3 - pushing this one to 3.6.3 as well.
Comment 6 Yaniv Kaul 2016-02-04 08:33:24 EST
awels - what's the Gerrit URL?
Comment 7 Petr Matyáš 2016-02-10 09:35:30 EST
Both VMs and Templates documentation loads properly.

Verified on 3.6.3-2
Comment 8 Eyal Edri 2016-03-14 08:48:35 EDT
RHEV 3.6 GA was released.
This bug didn't have any required doc text, closing.

Note You need to log in before you can comment on or make changes to this bug.