Bug 1294685 - Keystone errors and warnings are dumped to the console when deploying an overcloud
Keystone errors and warnings are dumped to the console when deploying an over...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: RHOS Maint
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 11:50 EST by Udi
Modified: 2017-03-20 20:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-20 20:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2015-12-29 11:50:27 EST
Description of problem:
After the deployment finishes you see the following messages on the console:

The following cert files already exist, use --rebuild to remove the existing files before regenerating:
/etc/keystone/ssl/certs/ca.pem already exists
/etc/keystone/ssl/private/signing_key.pem already exists
/etc/keystone/ssl/certs/signing_cert.pem already exists

The errors might be harmless, I don't know how or what to test to find out if it's really a problem or not.


Version-Release number of selected component (if applicable):
python-tripleoclient-0.0.11-5.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Deploy an overcloud
Comment 2 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 James Slagle 2016-10-14 11:16:13 EDT
Removing from OSP10, not a blocker/regression.

Further, I think this issue may be fixes since we no longer generate those keystone certificates locally via the client. Brad, can you confirm?
Comment 5 Brad P. Crochet 2017-03-20 20:44:23 EDT
I concur. Shouldn't be an issue anymore.

Note You need to log in before you can comment on or make changes to this bug.