Bug 1294795 - The hostname of HE don't appear correctly in "HE VM status" page.
The hostname of HE don't appear correctly in "HE VM status" page.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fabian Deutsch
cshao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 06:10 EST by cshao
Modified: 2016-02-10 15:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 21:41:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HE-VM-hostname (34.13 KB, image/png)
2015-12-30 06:10 EST, cshao
no flags Details
hostname-vm (3.61 MB, application/x-gzip)
2015-12-30 06:20 EST, cshao
no flags Details

  None (edit)
Description cshao 2015-12-30 06:10:40 EST
Created attachment 1110474 [details]
HE-VM-hostname

Description of problem:
After finished deploy HE, the hostname of HE don't appear correctly in "HE VM status" page.

RHEV-H 1
# hostname
cshaoh.redhat.com

RHEV-H 2
# hostname
cshaohadd.redhat.com

HE VM
# hostname
cshaohe.redhat.com


# hosted-engine --vm-status
--== Host 1 status ==--

Status up-to-date                  : True
Hostname                           : cshaoh.redhat.com
Host ID                            : 1
Engine status                      : {"health": "good", "vm": "up", "detail": "up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : 9c5aa56a
Host timestamp                     : 1278


--== Host 2 status ==--

Status up-to-date                  : True
Hostname                           : cshaohadd.redhat.com
Host ID                            : 2
Engine status                      : {"reason": "vm not running on this host", "health": "bad", "vm": "down", "detail": "unknown"}
Score                              : 0
stopped                            : False
Local maintenance                  : True
crc32                              : d609b356
Host timestamp                     : 17621



Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151229.0 
ovirt-node-3.6.1-1.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-5.el7ev.noarch
rhev-m appliance: rhevm-appliance-20151228.0-2

How reproducible:
100%

Steps to Reproduce:
1. TUI install rhev-hypervisor7-7.2-20151229.0 
2. Setup Hosted Engine
3. Check "Hosted Engine VM status" on HE menu.
4. Focus on hostname line.

Actual results:
1. The hostname of HE don't appear correctly in "HE VM status" page.
2. Actually the hostname is for hypervisor but not HE VM.
3. If the hostname is for hypervisor, then the option "Hosted Engine VM status" should be changed to "Hosted status".

Expected results:
The hostname of HE can show correctly.

Additional info:
Comment 1 cshao 2015-12-30 06:20 EST
Created attachment 1110475 [details]
hostname-vm
Comment 2 Yaniv Kaul 2015-12-30 06:30:32 EST
I honestly don't understand what the bug is. The VM status present on which *hosts* it may run - and for those hosts it provides the host name.

Please clarify, or close as NOTABUG.
Comment 3 cshao 2015-12-30 21:41:48 EST
(In reply to Yaniv Kaul from comment #2)
> I honestly don't understand what the bug is. The VM status present on which
> *hosts* it may run - and for those hosts it provides the host name.
> 
> Please clarify, or close as NOTABUG.


I see. Thank you for the explanation. I was confuse the hostname in the beginning.

Close the bug as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.