Bug 1294913 - [abrt] iptstate: operator delete(): iptstate killed by SIGABRT
[abrt] iptstate: operator delete(): iptstate killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iptstate (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ea284f65246ebbedcb907f2bb35...
:
: 1330780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 18:41 EST by Martin Jackson
Modified: 2016-12-02 22:20 EST (History)
8 users (show)

See Also:
Fixed In Version: iptstate-2.2.6-1.fc25 iptstate-2.2.6-1.fc24 iptstate-2.2.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 18:29:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (117.54 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: cgroup (194 bytes, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: core_backtrace (1.90 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: dso_list (1.11 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: environ (2.15 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: maps (5.46 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: mountinfo (3.19 KB, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: open_fds (185 bytes, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: proc_pid_status (979 bytes, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
File: var_log_messages (305 bytes, text/plain)
2015-12-30 18:41 EST, Martin Jackson
no flags Details
Patch updating the package (2.34 KB, patch)
2016-10-25 10:56 EDT, Jason Tibbitts
no flags Details | Diff

  None (edit)
Description Martin Jackson 2015-12-30 18:41:29 EST
Description of problem:


Version-Release number of selected component:
iptstate-2.2.5-7.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        iptstate
crash_function: operator delete
executable:     /usr/sbin/iptstate
global_pid:     2179
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 operator delete at ../../../../libstdc++-v3/libsupc++/del_op.cc:46
 #7 __gnu_cxx::new_allocator<char>::deallocate at /usr/include/c++/5.1.1/ext/new_allocator.h:110
 #8 __gnu_cxx::__alloc_traits<std::allocator<char> >::deallocate at /usr/include/c++/5.1.1/ext/alloc_traits.h:185
 #9 std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_destroy at /usr/include/c++/5.1.1/bits/basic_string.h:185
 #10 std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_dispose at /usr/include/c++/5.1.1/bits/basic_string.h:180
 #11 std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string at /usr/include/c++/5.1.1/bits/basic_string.h:544
 #12 table_t::~table_t at iptstate.cc:138
 #13 std::_Destroy<table_t> at /usr/include/c++/5.1.1/bits/stl_construct.h:93
 #14 std::_Destroy_aux<false>::__destroy<table_t*> at /usr/include/c++/5.1.1/bits/stl_construct.h:103
 #15 std::_Destroy<table_t*> at /usr/include/c++/5.1.1/bits/stl_construct.h:126
Comment 1 Martin Jackson 2015-12-30 18:41:34 EST
Created attachment 1110657 [details]
File: backtrace
Comment 2 Martin Jackson 2015-12-30 18:41:35 EST
Created attachment 1110658 [details]
File: cgroup
Comment 3 Martin Jackson 2015-12-30 18:41:36 EST
Created attachment 1110659 [details]
File: core_backtrace
Comment 4 Martin Jackson 2015-12-30 18:41:37 EST
Created attachment 1110660 [details]
File: dso_list
Comment 5 Martin Jackson 2015-12-30 18:41:38 EST
Created attachment 1110661 [details]
File: environ
Comment 6 Martin Jackson 2015-12-30 18:41:39 EST
Created attachment 1110662 [details]
File: limits
Comment 7 Martin Jackson 2015-12-30 18:41:40 EST
Created attachment 1110663 [details]
File: maps
Comment 8 Martin Jackson 2015-12-30 18:41:41 EST
Created attachment 1110664 [details]
File: mountinfo
Comment 9 Martin Jackson 2015-12-30 18:41:42 EST
Created attachment 1110665 [details]
File: namespaces
Comment 10 Martin Jackson 2015-12-30 18:41:43 EST
Created attachment 1110666 [details]
File: open_fds
Comment 11 Martin Jackson 2015-12-30 18:41:44 EST
Created attachment 1110667 [details]
File: proc_pid_status
Comment 12 Martin Jackson 2015-12-30 18:41:45 EST
Created attachment 1110668 [details]
File: var_log_messages
Comment 13 Gordon Martin 2016-03-19 21:01:02 EDT
Similar problem has been detected:

May be related to id c1fe04db9e60b03bed9a347bcac74a99e9d43e53 https://bugzilla.redhat.com/show_bug.cgi?id=1294913.  i7z crashes immediatly after execution.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        iptstate
crash_function: operator delete
executable:     /usr/sbin/iptstate
global_pid:     13597
kernel:         4.4.5-300.fc23.x86_64
package:        iptstate-2.2.5-7.fc23
reason:         iptstate killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            0
Comment 14 carlos_sarmiento 2016-04-26 20:00:47 EDT
*** Bug 1330780 has been marked as a duplicate of this bug. ***
Comment 15 Dominik 'Rathann' Mierzejewski 2016-08-16 18:04:21 EDT
Similar problem has been detected:

Started iptstate as root. It dies after a few seconds.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        iptstate
crash_function: operator delete
executable:     /usr/sbin/iptstate
global_pid:     4442
kernel:         4.6.6-200.fc23.x86_64
package:        iptstate-2.2.5-7.fc23
reason:         iptstate killed by SIGABRT
runlevel:       N 3
type:           CCpp
uid:            0
Comment 16 Jason Tibbitts 2016-10-24 13:37:53 EDT
This crash is still around in F24 and I'm pretty sure F25 and rawhide as well.  Version 2.2.6 has been available upstream for a couple of months and supposedly fixes many crashes.

I can update for it if you like.
Comment 17 Dominik 'Rathann' Mierzejewski 2016-10-24 15:24:52 EDT
Confirmed on F24 (iptstate-2.2.5-8.fc24.x86_64). I don't have time to do the update myself, but I will test 2.2.6 if you do it.
Comment 18 Martin Jackson 2016-10-24 22:32:56 EDT
Locally, I was able to rebuild the RPM and it looks like the crash in question is fixed by the update.

The RPM requires that the reference to README be changed to README.md but otherwise compiles on x86_64 without incident.
Comment 19 Jason Tibbitts 2016-10-25 10:56 EDT
Created attachment 1213945 [details]
Patch updating the package

Here's a patch which updates the package and cleans up the spec.  (I added the upstream signature but not the signature check as those macros aren't in place quite yet.)
Comment 20 Fedora Update System 2016-10-25 20:52:00 EDT
iptstate-2.2.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fcb4e6a183
Comment 21 Fedora Update System 2016-10-25 23:21:22 EDT
iptstate-2.2.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a8641f9eac
Comment 22 Fedora Update System 2016-10-26 00:24:21 EDT
iptstate-2.2.6-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-48bc6a3fe4
Comment 23 Fedora Update System 2016-10-26 18:29:46 EDT
iptstate-2.2.6-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2016-10-26 23:19:40 EDT
iptstate-2.2.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2016-12-02 22:20:43 EST
iptstate-2.2.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.