Bug 1294962 - openstack-service help returns lots of "documentation not known" results
openstack-service help returns lots of "documentation not known" results
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-utils (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Lon Hohberger
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 04:59 EST by Udi
Modified: 2016-12-02 07:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 07:48:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2015-12-31 04:59:50 EST
Description of problem:
If you run the command "openstack-service help" (instead of using --help as you should), this is what you get in return:


Documentation for neutron-dhcp-agent.service not known.

Documentation for neutron-openvswitch-agent.service not known.

Documentation for neutron-server.service not known.

Documentation for openstack-ceilometer-alarm-evaluator.service not known.

Documentation for openstack-ceilometer-alarm-notifier.service not known.

Documentation for openstack-ceilometer-api.service not known.

Documentation for openstack-ceilometer-central.service not known.

Documentation for openstack-ceilometer-collector.service not known.

Documentation for openstack-ceilometer-notification.service not known.

Documentation for openstack-glance-api.service not known.

Documentation for openstack-glance-registry.service not known.

Documentation for openstack-heat-api-cfn.service not known.

Documentation for openstack-heat-api-cloudwatch.service not known.

Documentation for openstack-heat-api.service not known.

Documentation for openstack-heat-engine.service not known.

Documentation for openstack-ironic-api.service not known.

Documentation for openstack-ironic-conductor.service not known.

Documentation for openstack-ironic-inspector-dnsmasq.service not known.

Documentation for openstack-ironic-inspector.service not known.

Documentation for openstack-keystone.service not known.

Documentation for openstack-nova-api.service not known.

Documentation for openstack-nova-cert.service not known.

Documentation for openstack-nova-compute.service not known.

Documentation for openstack-nova-conductor.service not known.

Documentation for openstack-nova-scheduler.service not known.

Documentation for openstack-swift-account-auditor.service not known.

Documentation for openstack-swift-account-reaper.service not known.

Documentation for openstack-swift-account-replicator.service not known.

Documentation for openstack-swift-account.service not known.

Documentation for openstack-swift-container-auditor.service not known.

Documentation for openstack-swift-container-replicator.service not known.

Documentation for openstack-swift-container-updater.service not known.

Documentation for openstack-swift-container.service not known.

Documentation for openstack-swift-object-auditor.service not known.

Documentation for openstack-swift-object-replicator.service not known.

Documentation for openstack-swift-object-updater.service not known.

Documentation for openstack-swift-object.service not known.

Documentation for openstack-swift-proxy.service not known.



Version-Release number of selected component (if applicable):
openstack-utils-2014.2-1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Run the command "openstack-service help" on the undercloud or the overcloud


Actual results:
Lots of "documentation not known" results...


Expected results:
It should say "unknown option help, use --help" or something similar. Or maybe it's really looking for some additional documentation - in which case it should find that documentation. Anybody know what was really supposed to happen?
Comment 3 Lon Hohberger 2016-01-04 17:05:00 EST
Since 'help' actually pulls up man pages when using systemd and LSB does not specify this operation, the only appropriate behavior I can think of is to simply pull up the openstack-service man page.
Comment 5 Mike McCune 2016-03-28 18:55:34 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Mike Burns 2016-12-02 07:48:54 EST
current versions in 8, 9, and 10RC all work correctly.

Note You need to log in before you can comment on or make changes to this bug.