This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294995 - [Storage Guide] Snapper section needs some clarifications
[Storage Guide] Snapper section needs some clarifications
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Storage_Administration_Guide (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Milan Navratil
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 10:26 EST by Karl Hastings
Modified: 2016-11-14 05:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-14 05:56:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Hastings 2015-12-31 10:26:28 EST
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Storage_Administration_Guide/index.html#snapper-undochange

Section Number and Name: 
13.5. Reverse Changes in Between Snapshots

Describe the issue: 
"NOTE: PLACE HOLDER DIAGRAM"  Not what we want in the published document.

Also the warning in incomplete:
"Important
This will not revert the snapper volume back to its original state and does not provide data consistency. Any file modification that occurs outside of the specified range (for example, after snapshot 2) will remain unchanged after reverting back (for example, to the state of snapshot 1). For example, should the undochange be run to undo the creation of a user, any files owned by that user may still remain.
There is also no mechanism to ensure file consistency as a snapshot is made, so any inconsistencies that already exist can be transfered back to the snapshot when the undochange command is used. "

The upstream snapper documentation is pretty specific that you should *not* use snapper to try to "undochange" the root filesystem.  (i.e. "snapper -c root create --command "yum update"  followed later by a "snapper -c root undochange y..x" is likely to result in catastrophic failure...  i.e. is not supported).

Upstream snapper SuSe snapper has the "rollback" command (which we appear to not include) which handles this usecase.

This limitation needs to be very clear.

Finally, the snapper section is *very* heavy on btrfs examples which are not yet supported.  Should probably have all the examples use lvm since that is what is supported.

Suggestions for improvement: 
See above

Additional information:
Comment 22 Milan Navratil 2016-11-14 05:56:09 EST
An updated version of the Red hat Enterprise Linux 7 Storage Administration Guide is now available on the Customer Portal:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Storage_Administration_Guide/index.html

(The update with the fix pointed out in comment 18 will be available soon.)

Note You need to log in before you can comment on or make changes to this bug.