Bug 129501 - LTC10415-service --list-all line 61 gets a seg fault
LTC10415-service --list-all line 61 gets a seg fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssl (Show other bugs)
3.0
s390x Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 15:50 EDT by Bill Goodrich
Modified: 2015-03-04 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 21:12:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Goodrich 2004-08-09 15:50:01 EDT
The following has be reported by IBM LTC:  
service --list-all  line 61 gets a seg fault
Hardware Environment:
z900
Software Environment:
rhel3 u3 public beta

Steps to Reproduce:
1. service --list-all
2.
3.

Actual Results:
atd (pid 802) is running...
auditd (pid 625) is running...
Configured Mount Points:
------------------------

Active Mount Points:
--------------------
crond (pid 770) is running...
cupsd (pid 688) is running...
dc_client is stopped
dc_server is stopped
/etc/init.d/halt.s390init: call me as 'halt' or 'reboot' please!
httpd is stopped
Firewall is stopped.
Table: filter
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain RH-Firewall-1-INPUT (0 references)
target     prot opt source               destination         

irqbalance is stopped
mdadm (pid 605) is running...
mdmpd is stopped
Server address not specified in /etc/sysconfig/netdump
Configured devices:
lo eth0
Currently active devices:
lo eth0
rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped
rpc.statd is stopped
nscd is stopped
ntpd is stopped
/sbin/service: line 61:  6277 Segmentation fault      env -i LANG=$LANG
PATH=$PATH TERM=$TERM "${SERVICEDIR}/${SERVICE}" status
portmap (pid 594) is running...
Process accounting is disabled.
The random data source exists
rhnsd (pid 812) is running...
saslauthd is stopped
sendmail (pid 760 751) is running...
smartd is stopped
smbd (pid 3922 3918) is running...
nmbd (pid 3923) is running...
squid is stopped
squid: ERROR: No running copy
sshd (pid 3236 820 707) is running...
syslogd (pid 579) is running...
klogd (pid 583) is running...
tux is stopped
Xvnc is stopped
vsftpd (pid 6103 6101 730) is running...
winbindd is stopped
xfs (pid 793) is running...
xinetd (pid 721) is running...
ypbind is stopped


Expected Results:
Shouldn't seg fault

Additional Information:
Comment 1 Suzanne Hillman 2004-08-10 17:27:17 EDT
There _is_ no 'service --list-all', that I can find. There is a
--status-all, however.

And, /sbin/service is part of initscripts, not serviceconf. What
version of initscripts is on your system?

Finally, I was not able to reproduce this on a s390x machine here - is
this something you can regularly reproduce?
Comment 2 Suzanne Hillman 2004-08-10 17:28:26 EDT
(at least, according to "rpm -q --whatprovides /sbin/service", it's
part of initiscripts)
Comment 3 Bill Goodrich 2004-08-17 16:05:22 EDT
Sorry! I messed up on that one. It's --status-all. 

initscripts-7.31.15.EL-1

It always fails in the same place:
/sbin/service: line 61: 18389 Segmentation fault      env -i
LANG=$LANG PATH=$PATH TERM=$TERM "${SERVICEDIR}/${SERVICE}" status

I checked my 31 bit image and it runs clean there. 
Comment 4 Bill Goodrich 2004-08-17 16:08:28 EDT
Sorry! I messed up on that one. It's --status-all. 

initscripts-7.31.15.EL-1

It always fails in the same place:
/sbin/service: line 61: 18389 Segmentation fault      env -i
LANG=$LANG PATH=$PATH TERM=$TERM "${SERVICEDIR}/${SERVICE}" status

I checked my 31 bit image and it runs clean there. 
Comment 5 Bill Nottingham 2004-08-19 15:17:12 EDT
This is a particular service segfaulting.

If you run 'service <blah> status' by hand, which one segfaults?
Comment 6 Bill Goodrich 2004-09-20 14:29:39 EDT
The failure occurs between ntpd and portmap. The service in
/etc/init.d between those two services is pkcsslotd.

service --status pkcsslotd
--status: unrecognized service

This is a zSeries specific service that is used in support of the
zSeries Cryptographic hardware. 

nscd is stopped
ntpd is stopped
/sbin/service: line 61:  2241 Segmentation fault      env -i
LANG=$LANG PATH=$PATH TERM=$TERM "${SERVICEDIR}/${SERVICE}" status
portmap (pid 383) is running...
Process accounting is disabled.
Comment 7 Bill Goodrich 2004-09-20 14:31:43 EDT
Brock, does this happen on your U3 zSeries images?
Comment 8 Phil Knirsch 2004-10-18 12:08:47 EDT
Is this bug by any change related to that one here?

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133839

If yes, then i can include the same fix for RHEL3 for the next update.

Read ya, Phil
Comment 9 Bill Goodrich 2004-10-18 17:17:16 EDT
Phil, I don't know if it is related or not. 
It's the same as: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133091

Here's some comments from you from that one:
 Additional Comment #10 From Phil Knirsch (pknirsch@redhat.com)  on
2004-09-27 10:47 -------

Oh, thats right.

Including fix in next openCryptoki package.

Read ya, Phil

I guessing if we get the new openCryptoki we can wrap this one up. 
I hope that helps.
Comment 10 Phil Knirsch 2004-11-17 09:03:32 EST
Just verified, it's really the initscript fix. Will open an errata for
RHEL3 for openCryptoki.

Read ya, Phil
Comment 11 Phil Knirsch 2004-12-09 08:30:51 EST
Packages done, errata created. Fixed packages will be in RHEL3-U4

Read ya, Phil
Comment 12 John Flanagan 2004-12-21 21:12:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-648.html
Comment 14 IBM Bug Proxy 2005-01-05 09:14:29 EST
----- Additional Comments From hannsj_uhl@de.ibm.com  2005-01-05 09:06 EST -------
fyi ... the last update from the Red Hat bugzilla 129501 was from 12/21
as follows:
"
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-648.html
"
Then the bugzilla was closed on the Red Hat side ...
... closing this bugzilla on the LTC side now. 

Note You need to log in before you can comment on or make changes to this bug.