Bug 1295038 - kmod weak-modules is looking for /sbin/dracut (/usr/sbin/dracut) instead of /usr/bin/dracut
kmod weak-modules is looking for /sbin/dracut (/usr/sbin/dracut) instead of /...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kmod (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: kmod development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-01 04:03 EST by Stuart Rothrock
Modified: 2016-02-05 16:50 EST (History)
3 users (show)

See Also:
Fixed In Version: kmod-22-2.fc23 kmod-22-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 13:21:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Rothrock 2016-01-01 04:03:29 EST
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36
Build Identifier: 

kmod will fail running weak-modules referencing /sbin/dracut instead of /usr/bin/dracut

Reproducible: Always

Steps to Reproduce:
1. run weak-modules or any kmod command that calls weak-modules
2.
3.
Actual Results:  
root> weak-modules
weak-modules: this tool requires a dracut-enabled kernel

Expected Results:  
non-error exit

workaround: ln -s /usr/bin/dracut /usr/sbin/dracut
Comment 1 Josh Boyer 2016-01-04 09:01:02 EST
Harald, it looks like you dropped the sbin compat symlink with Fedora commit ca29758ec2376c3960bdae90e65564d959a70130 which was the update to dracut 042.  Was that intentional?

I can change kmod to look in /usr/bin/ unconditionally and it should still work, but I was surprised this changed in f23.
Comment 2 Harald Hoyer 2016-01-07 06:01:36 EST
(In reply to Josh Boyer from comment #1)
> Harald, it looks like you dropped the sbin compat symlink with Fedora commit
> ca29758ec2376c3960bdae90e65564d959a70130 which was the update to dracut 042.
> Was that intentional?
> 
> I can change kmod to look in /usr/bin/ unconditionally and it should still
> work, but I was surprised this changed in f23.

sorry, yes, the change was intentional
Comment 3 Josh Boyer 2016-01-07 14:21:39 EST
Fixed in Fedora git.
Comment 4 Fedora Update System 2016-01-25 15:46:06 EST
kmod-22-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8cfb56d04
Comment 5 Fedora Update System 2016-01-25 15:46:08 EST
kmod-22-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-722c92c616
Comment 6 Fedora Update System 2016-01-25 23:21:33 EST
kmod-22-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8cfb56d04
Comment 7 Fedora Update System 2016-01-25 23:27:12 EST
kmod-22-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-722c92c616
Comment 8 Fedora Update System 2016-01-28 13:21:31 EST
kmod-22-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-02-05 16:50:54 EST
kmod-22-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.