Bug 1295058 - [abrt] evolution-data-server: g_mutex_clear(): evolution-calendar-factory-subprocess killed by SIGABRT
[abrt] evolution-data-server: g_mutex_clear(): evolution-calendar-factory-sub...
Status: CLOSED DUPLICATE of bug 1227968
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ec5935994cf244c5764867db873...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-01 09:09 EST by Darragh Bailey
Modified: 2016-04-30 05:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 13:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.92 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: cgroup (190 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: core_backtrace (20.54 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: dso_list (17.34 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: environ (844 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: maps (78.92 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: mountinfo (3.79 KB, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: open_fds (830 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: proc_pid_status (1022 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-01-01 09:09 EST, Darragh Bailey
no flags Details

  None (edit)
Description Darragh Bailey 2016-01-01 09:09:26 EST
Description of problem:
Just logged in and got the error report. Not using evolution, nor AFAICR have I configured any email accounts for it on this system.

Version-Release number of selected component:
evolution-data-server-3.18.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory-subprocess --factory contacts --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.Calendarx3845x2 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/Calendar/3845/2
crash_function: g_mutex_clear
executable:     /usr/libexec/evolution-calendar-factory-subprocess
global_pid:     3880
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 g_mutex_clear at gthread-posix.c:1302
 #3 e_flag_free at e-flag.c:232
 #4 e_client_wait_for_connected_sync at e-client.c:2018
 #5 client_wait_for_connected_thread at e-client.c:1863
 #6 g_task_thread_pool_thread at gtask.c:1287
 #8 g_thread_proxy at gthread.c:778

Potential duplicate: bug 1227968
Comment 1 Darragh Bailey 2016-01-01 09:09:31 EST
Created attachment 1110904 [details]
File: backtrace
Comment 2 Darragh Bailey 2016-01-01 09:09:32 EST
Created attachment 1110905 [details]
File: cgroup
Comment 3 Darragh Bailey 2016-01-01 09:09:34 EST
Created attachment 1110906 [details]
File: core_backtrace
Comment 4 Darragh Bailey 2016-01-01 09:09:36 EST
Created attachment 1110907 [details]
File: dso_list
Comment 5 Darragh Bailey 2016-01-01 09:09:37 EST
Created attachment 1110908 [details]
File: environ
Comment 6 Darragh Bailey 2016-01-01 09:09:38 EST
Created attachment 1110909 [details]
File: limits
Comment 7 Darragh Bailey 2016-01-01 09:09:40 EST
Created attachment 1110910 [details]
File: maps
Comment 8 Darragh Bailey 2016-01-01 09:09:41 EST
Created attachment 1110911 [details]
File: mountinfo
Comment 9 Darragh Bailey 2016-01-01 09:09:43 EST
Created attachment 1110912 [details]
File: namespaces
Comment 10 Darragh Bailey 2016-01-01 09:09:44 EST
Created attachment 1110913 [details]
File: open_fds
Comment 11 Darragh Bailey 2016-01-01 09:09:45 EST
Created attachment 1110914 [details]
File: proc_pid_status
Comment 12 Darragh Bailey 2016-01-01 09:09:47 EST
Created attachment 1110915 [details]
File: var_log_messages
Comment 13 Milan Crha 2016-01-18 13:20:25 EST
Thanks for a bug report. This particular one had been reported already, thus I'm marking it as a duplicate.

The crash happened in the calendar factory, which is providing calendar data for any application which asks for it.

*** This bug has been marked as a duplicate of bug 1227968 ***

Note You need to log in before you can comment on or make changes to this bug.