Bug 1295083 - i3status-2.10 is available
i3status-2.10 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: i3status (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christian Dersch
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-01 19:12 EST by Upstream Release Monitoring
Modified: 2016-06-06 15:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 15:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 2.10 (#1295083) (958 bytes, patch)
2016-01-01 19:13 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-01-01 19:12:47 EST
Latest upstream release: 2.10
Current version/release in rawhide: 2.9-1.fc24
URL: http://i3wm.org/i3status/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-01-01 19:13:16 EST
Created attachment 1110950 [details]
[patch] Update to 2.10 (#1295083)
Comment 2 Upstream Release Monitoring 2016-01-01 19:16:19 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=12378973
Comment 3 Johannes Pfrang 2016-01-28 07:45:44 EST
Could someone please push this to updates-testing? Pango support allows some really nice new styling options:

http://imgur.com/3a0BOWf

(Source: https://www.reddit.com/r/i3wm/comments/3z4l9x/i3status_210_released_with_pango_support/)

Also, the changelog notes significantly reduced battery consumption on systems that use PulseAudio.
Comment 4 Martin Preisler 2016-01-29 08:58:11 EST
Hi,
new upstream version needs 2 new dependencies - libnl3 and pulseaudio-libs. I am doing a new build for rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=12725535

Do you think it makes sense to push this to F23?
Comment 5 Upstream Release Monitoring 2016-01-29 09:10:23 EST
mpreisle's i3status-2.10-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=714722
Comment 6 Upstream Release Monitoring 2016-02-03 22:18:40 EST
releng's i3status-2.10-2.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=720398
Comment 7 Johannes Pfrang 2016-02-04 14:59:56 EST
I'd appreciate a push to F23 if it isn't too cumbersome.
The only notable regression I can see comparing 2.10..master on github is is a segfault due to a missing nullcheck if the config contains an invalid path for `disk`, but that can easily be worked around by the user fixing their config file.

https://github.com/i3/i3status/issues/92
Comment 8 Fedora Admin XMLRPC Client 2016-02-26 12:37:51 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2016-02-26 12:38:43 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fabio Alessandro Locati 2016-06-06 15:10:43 EDT
I'm closing this since in F24+ is present

Note You need to log in before you can comment on or make changes to this bug.