Bug 1295121 - Builders wait when 200 elements are waiting
Builders wait when 200 elements are waiting
Status: CLOSED WONTFIX
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-02 10:17 EST by Fabio Alessandro Locati
Modified: 2016-01-27 08:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 08:04:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Alessandro Locati 2016-01-02 10:17:34 EST
When 200 builds are queued, all other builds wait even if there are no currently running builds. This happended due to the PPC64 temporary block and all builds (PPC64, x86, x86_64) were blocked. I solved temporally removing some of my jobs that had ppc64 builds to do.
Comment 1 Miroslav Suchý 2016-01-27 08:04:08 EST
This is intentionally due some other behaviour of OpenStack which affect us, where you can not have more than 200 VM per one tenant.
The long PPC queue was caused by some other issue, which was resolved and should not happen again.
So the real issue is that "when there is more than 200 task claiming to be running, no other task is executed" and that is and will be intentional.
Such situation need manual intervention anyway.

Note You need to log in before you can comment on or make changes to this bug.