Bug 1295147 - Clementine does not appear in panel nor opens a window (KDE spin, Fedora 22)
Clementine does not appear in panel nor opens a window (KDE spin, Fedora 22)
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: clementine (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-02 18:50 EST by David Tonhofer
Modified: 2016-07-19 14:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:38:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2016-01-02 18:50:49 EST
Description of problem:
=======================

KDE Fedora 22, with recent updates.

Starting "clementine" from the command line or the KDE Start Menu results in no window nor an icon in the system tray Entry for Clementine is marked "shown"). 

The Clementine process is active though:

\_ /bin/bash
      \_ clementine
          \_ /usr/bin/clementine-tagreader /tmp/clementine_498778321
          \_ /usr/bin/clementine-tagreader /tmp/clementine_1197872811

In the shell, we read:

00:42:36.212 WARN  unknown
libpng warning: iCCP: known incorrect sRGB profile 
00:42:36.322 WARN  unknown
libpng warning: iCCP: known incorrect sRGB profile 
00:42:36.479 WARN  unknown
Object::connect: No such signal QtSingleApplication::messageReceived(QByteArray) 
00:42:36.479 WARN  unknown
Object::connect:  (sender name:   'clementine') 
00:42:36.479 WARN  unknown
Object::connect:  (receiver name: 'MainWindow') 

Version-Release number of selected component
============================================

$ rpm --query qtsingleapplication
qtsingleapplication-2.6.1-23.fc22.x86_64

$ rpm --query qtsinglecoreapplication
qtsinglecoreapplication-2.6.1-23.fc22.x86_64

$ rpm --query clementine
clementine-1.2.3-10.fc22.x86_64

Tried to:
=========

$ dnf downgrade qtsingleapplication qtsinglecoreapplication

$ rpm --query qtsingleapplication
qtsingleapplication-2.6.1-17.fc22.x86_64

$ rpm --query qtsinglecoreapplication
qtsinglecoreapplication-2.6.1-17.fc22.x86_64

But that did not help!

How reproducible:
=================

Always

Steps to Reproduce:
===================

1. Start clementine
2. No Window


Additional info:
================

Keep your hair short!
Comment 1 David Tonhofer 2016-02-11 08:35:03 EST
Still happening... 

I tried:

$ cd ~/.config
$ mv Clementine/ ~/Clementine.bak
$ clementine &

The main window appears, but there is still no icon in the panel.

Once you close the main window, back to square one. Clementine is running but this fact cannot be seen in the GUI
Comment 2 Fedora End Of Life 2016-07-19 14:38:15 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.