Bug 1295186 - armv7hl kernel packages do not build with CONFIG_DRM_DW_HDMI_AHB_AUDIO=m
armv7hl kernel packages do not build with CONFIG_DRM_DW_HDMI_AHB_AUDIO=m
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-03 07:10 EST by billiboy
Modified: 2016-01-18 07:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 02:02:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filter dw_hdmi-ahb-audio.ko to kernel-modules package (618 bytes, patch)
2016-01-03 07:10 EST, billiboy
no flags Details | Diff
disable-etnaviv-generic.patch (308 bytes, patch)
2016-01-05 10:21 EST, billiboy
no flags Details | Diff

  None (edit)
Description billiboy 2016-01-03 07:10:33 EST
Created attachment 1111136 [details]
filter dw_hdmi-ahb-audio.ko to kernel-modules package

Description of problem:

armv7hl kernel packages do not build with CONFIG_DRM_DW_HDMI_AHB_AUDIO=m

Version-Release number of selected component (if applicable):

How reproducible:

always

Steps to Reproduce:

install recent kernel.src.rpm
enable "Synopsis Designware AHB Audio interface" (CONFIG_DRM_DW_HDMI_AHB_AUDIO=m) in config-armv7-generic
rpmbuild -ba kernel.spec

Actual results:

build will fail at depmod stage while packing kernel-core

Expected results:

full set of kernel packages build with dw_hdmi-ahb-audio.ko included

Additional info:

The resulting dw_hdmi-ahb-audio.ko depends on sound modules which reside in kernel-modules hence depmod for kernel-core packing stage will fail.
Fix this by moving dw_hdmi-ahb-audio.ko also to kernel-modules.
Applying filter-dw_hdmi-ahb-audio-to-kernel-modules.patch to filter-armv7hl.sh will do this.
Now out of the box Synopsis Designware HDMI Audio will be possible.
Comment 1 Josh Boyer 2016-01-03 10:33:33 EST
Fedora doesn't enable this module currently, so this isn't really a bug at the moment.  Are you requesting that we enable the module option you've specified?
Comment 2 billiboy 2016-01-03 16:29:02 EST
From this commit description "The module filters need to be updated" from [1] I got the impression it was planed to enable it again when figured out what need to be done.
I rebuild the kernel packages for a device with HDMI video interface and an imx6 SOC which has this IP on board (cubox-i).
It's a pity to have the video part available native and the sound part missing.
Since I figured out what was missing, my only intention was to share my findings as it works for me now.
My cubox-i will hopefully soon be running a mainline kernel, build from fedora kernel source package, with hardware accelerated 2D/3D support as etnaviv has started it's flight to mainline.

[1] http://pkgs.fedoraproject.org/cgit/kernel.git/commit/?id=bc28c746fc43d29ef9930aba1946dd78318e23d2
Comment 3 Laura Abbott 2016-01-04 12:41:16 EST
The patch looks okay but I'd like pbrobinson to review
Comment 4 Peter Robinson 2016-01-04 12:49:43 EST
(In reply to Laura Abbott from comment #3)
> The patch looks okay but I'd like pbrobinson to review

Give me a couple of days I actually have a patch series that does a bunch of updates to the module filters and this is on my list as I think it's also needed for rockchip too (and hence now aarch64)

I'm also already looking at the accel 2d/3d stuff too as it should land in 4.5
Comment 5 billiboy 2016-01-05 10:21 EST
Created attachment 1111861 [details]
disable-etnaviv-generic.patch
Comment 6 billiboy 2016-01-05 10:22:18 EST
FWIW

dw_hdmi-ahb-audio.ko is only required for the imx6 SOC dw_hdmi IP, rockchip is using different modules to support differences in the IP implementation between rockchip and frees
cale.

Oh, by the way, disable-etnaviv-generic.patch applied and linux-next etnaviv commits applied as patchset with this:
CONFIG_DRM_ETNAVIV=m
CONFIG_DRM_ETNAVIV_REGISTER_LOGGING=n
in config-local already works for me to build armv7hl kernel packages with etnaviv support.

This is also nice to have for on chip one time programmable fuse support:
CONFIG_NVMEM=m
CONFIG_NVMEM_IMX_OCOTP=m
CONFIG_ROCKCHIP_EFUSE=n
CONFIG_NVMEM_SUNXI_SID=n
CONFIG_QCOM_QFPROM=n
Maybe also for rockchip and the others.
Comment 7 billiboy 2016-01-05 11:44:41 EST
FWIW
here is a proper explanation available [1]. So only imx6 for now.

[1] http://lists.freedesktop.org/archives/dri-devel/2016-January/097994.html
Comment 8 Peter Robinson 2016-01-17 02:02:40 EST
With the updated filter rules and DRM_DW_HDMI_AHB_AUDIO is now enabled for the next rawhide build.

ETNAVIV will happen when it lands.

Will review the other options later
Comment 9 Peter Robinson 2016-01-17 02:25:27 EST
And now various NVMEM drivers enabled. Thanks for the feedback
Comment 10 billiboy 2016-01-18 06:57:00 EST
Thanks for the consideration.
Will patiently wait for the kernel-4.5.0-0.rc1.git0.1.fc24 spin [1].

[1] https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=984065055e6e39f8dd812529e11922374bd39352
Comment 11 Peter Robinson 2016-01-18 07:28:01 EST
(In reply to billiboy from comment #10)
> Thanks for the consideration.
> Will patiently wait for the kernel-4.5.0-0.rc1.git0.1.fc24 spin [1].

Yes, we should have etnaviv too :)

Note You need to log in before you can comment on or make changes to this bug.