Bug 1295286 - Excessive lose formatting warning in Evolution
Excessive lose formatting warning in Evolution
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 01:09 EST by Feng Yu
Modified: 2016-01-19 12:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 12:17:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Feng Yu 2016-01-04 01:09:20 EST
Description of problem:

A dialog pops up asking about losing formatting replying HTML emails, every time.

Version-Release number of selected component (if applicable):
3.16

How reproducible:

Every time.

Steps to Reproduce:

1. Set the default email format to text
2. reply any html email

Actual results:

A pop up window asks to confirm the email will lose formatting. No way to disable the warning -- interrupting the work flow of replying an email.

Expected results:

At least a way to disable this warning. A fix was tagged for 3.17 but Fedora shall consider a back-port for F22 (which uses 3.16.), since F22 is still maintained and the current behavior is very annoying. 

How did people survive this for this long without reporting a bug, seriously? I guess because most people who reply email in plain text do not use Evolution?

Additional info:
Upstream patch
https://github.com/GNOME/evolution/commit/96a4ac56526bf6b0bdb9bb5765acfb7e9280384a
Comment 1 Milan Crha 2016-01-19 12:17:40 EST
Thanks for a bug report. I'm sorry, but I'm not going to backport the change. There had been done many more serious fixes than this in the evolution with compare of the 3.16 and 3.18 series, not counting all the fixes in the mail composer part itself, thus it's better to update to more recent Fedora than to randomly pick upstream patches and request their backport.

Note You need to log in before you can comment on or make changes to this bug.