Bug 129542 - Postfix determines $myhostname incorrectly
Summary: Postfix determines $myhostname incorrectly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-10 09:10 UTC by Andrew Novikov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 12:04:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Novikov 2004-08-10 09:10:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
When I start postfix it wrongly determines the value of the
$myhostname variable as localhost.localdomain although gethostname()
returns real DNS domain name (fqdn btw). I believe the reason is that
reverce DNS record for the postfix' host points to a different name
than gethostname() returns. After disabling
postfix-hostname-fqdn.patch everything started to work as expected.


Version-Release number of selected component (if applicable):
postfix-2.1.4-1

How reproducible:
Always

Steps to Reproduce:
Make reverce dns record and host name different, then start postfix.

Additional info:
postfix-2.0.18-4 works OK

Comment 1 Thomas Woerner 2004-08-23 12:04:09 UTC
I think you have to fix the dns server.
Closing as "NOT A BUG".


Note You need to log in before you can comment on or make changes to this bug.