Bug 129544 - /etc/DIR_COLORS doesn't consider "konsole" a colorizable terminal
Summary: /etc/DIR_COLORS doesn't consider "konsole" a colorizable terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-10 09:30 UTC by Felipe Alfaro Solana
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 5.2.1-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 12:42:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Alfaro Solana 2004-08-10 09:30:27 UTC
Description of problem: 
Starting with KDE 3.3, it seems that Konsole sets TERM=konsole. This 
breaks dircolors. Running "dircolors --sh /etc/DIR_COLORS" simply 
returns an empty LS_COLORS. 
 
To fix this problem, the following line must be added 
to /etc/DIR_COLORS and /etc/DIR_COLORS.xterm: 
 
TERM konsole 
 
Now, running "dircolors --sh /etc/DIR_COLORS" will correctly 
evaluate the LS_COLORS environment variable. 
 
Version-Release number of selected component (if applicable): 
coreutils-5.2.1-19 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Under KDE 3.3 Beta 2 or newer, start a Konsole terminal. 
2. echo $TERM 
   TERM=konsole 
3. dircolors --sh /etc/DIR_COLORS 
   LS_COLORS='' 
   export LS_COLORS 
   
Actual results: 
/etc/DIR_COLORS doesn't consider "konsole" a colorizable terminal. 
 
Expected results: 
/etc/DIR_COLORS must consider "konsole" a colorizable terminal. 
 
Additional info: 
Also happens with coreutils-5.2.1-18

Comment 1 Sammy 2004-08-10 13:24:49 UTC
This is really not because of kde-3.3 but the new ncurses. Previously 
konsole was set as xterm but the new /etc/profile.d/term.sh sets it 
as konsole and thus the problem. Previously xterm entry in ncurses 
was patched to make these colors work...this was deemed a problem 
for konsole and not ncurses and the patch was removed and the current 
solution implemented. 
FYI 
 
PS: You may want to cc this to havill@redhat.com 


Note You need to log in before you can comment on or make changes to this bug.