Bug 1295527 - xdelta: error XD3_TOOFARBACK
xdelta: error XD3_TOOFARBACK
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xdelta (Show other bugs)
23
All All
unspecified Severity low
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 13:40 EST by Oliver Paukstadt
Modified: 2016-01-13 00:21 EST (History)
1 user (show)

See Also:
Fixed In Version: xdelta-3.0.11-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 00:21:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Paukstadt 2016-01-04 13:40:38 EST
Description of problem:
Ran several times into an xdelta error message/code:
XD3_TOOFARBACK

This is problem was fixed in 3.0.10 which was released in July 2015.
f23 includes 3.0.9

https://github.com/jmacd/xdelta/issues/188
Comment 1 Fedora Update System 2016-01-11 00:33:12 EST
xdelta-3.0.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-777d879d69
Comment 2 Fedora Update System 2016-01-11 08:52:33 EST
xdelta-3.0.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-777d879d69
Comment 3 Oliver Paukstadt 2016-01-11 14:17:53 EST
Thanks.

What about adding xz-devel to the requirements? This would enable secondary compression lzma which seems to be more efficient than any other.

I did a package rebuild on my system and all tests where successful. I was able to remove patch1 as well.
Comment 4 Fedora Update System 2016-01-11 17:45:23 EST
xdelta-3.0.11-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-10ae68c62f
Comment 5 Pavel Raiskup 2016-01-11 17:47:11 EST
Done, thanks for the report and hints!
Comment 6 Oliver Paukstadt 2016-01-12 02:06:09 EST
For my real life tests everything works fine.

Thanks.
Comment 7 Fedora Update System 2016-01-12 04:52:30 EST
xdelta-3.0.11-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-10ae68c62f
Comment 8 Pavel Raiskup 2016-01-12 04:58:47 EST
Oliver, than please leave a karma in bodhi!  Thanks.
Comment 9 Fedora Update System 2016-01-13 00:21:18 EST
xdelta-3.0.11-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.