Bug 1295541 - ERROR: openstack 'ArgumentParser' object has no attribute 'debug'
ERROR: openstack 'ArgumentParser' object has no attribute 'debug'
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
7.0 (Kilo)
Unspecified Linux
unspecified Severity low
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 14:22 EST by tkammer
Modified: 2016-10-14 18:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 18:24:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tkammer 2016-01-04 14:22:43 EST
Description of problem:
While trying to list the arguments provided by "openstack overcloud" I got the following error during the list of arguments:
""
Could not load EntryPoint.parse('overcloud_netenv_validate = rdomanager_oscplugin.v1.overcloud_netenv_validate:ValidateOvercloudNetenv')
ERROR: openstack 'ArgumentParser' object has no attribute 'debug'
"""

How reproducible:
100%

Steps to Reproduce:
1. install an undecloud using osp director
2. run "source ~/stackrc; openstack --help"
3. See failure

Actual results:
Could not load EntryPoint.parse('overcloud_netenv_validate = rdomanager_oscplugin.v1.overcloud_netenv_validate:ValidateOvercloudNetenv')
ERROR: openstack 'ArgumentParser' object has no attribute 'debug'

Expected results:
Full list of options
Comment 2 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Jason E. Rist 2016-10-14 18:24:33 EDT
This is not a bug in the current release:
[stack@instack tripleo-common]$ openstack overcloud --help
WARNING: openstackclient.common.utils is deprecated and will be removed after Jun 2017. Please use osc_lib.utils
Command "overcloud" matches:
  overcloud deploy
  overcloud execute
  overcloud image build
  overcloud image upload
  overcloud netenv validate
  overcloud node configure
  overcloud node delete
  overcloud node import
  overcloud node introspect
  overcloud node provide
  overcloud plan create
  overcloud plan delete
  overcloud plan list
  overcloud profiles list
  overcloud profiles match
  overcloud update stack
  overcloud upgrade

Note You need to log in before you can comment on or make changes to this bug.