Bug 1295565 - tempest failure tempest.api.network.test_ports.PortsTestJSON.test_create_port_in_allowed_allocation_pools[
tempest failure tempest.api.network.test_ports.PortsTestJSON.test_create_port...
Status: CLOSED DUPLICATE of bug 1295564
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 16:14 EST by wes hayutin
Modified: 2016-04-18 03:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 16:20:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2016-01-04 16:14:41 EST
Description of problem:

2016-01-04 14:51:41,701 847 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: {"port": {"network_id": "96779667-fe9c-4b38-bd4f-eda08eea0f6f"}}
    Response - Headers: {'status': '409', 'content-length': '164', 'connection': 'close', 'date': 'Mon, 04 Jan 2016 19:51:40 GMT', 'content-type': 'application/json; charset=UTF-8', 'x-openstack-request-id': 'req-2969d075-20d5-4ae7-b5e7-5d4c2679689a'}
        Body: {"NeutronError": {"message": "No more IP addresses available on network 96779667-fe9c-4b38-bd4f-eda08eea0f6f.", "type": "IpAddressGenerationFailure", "detail": ""}}
2016-01-04 14:51:43,336 847 INFO     [tempest_lib.common.rest_client] Request (PortsTestJSON:_run_cleanups): 204 DELETE http://172.16.23.110:9696/v2.0/subnets/5ce0c602-f565-4adc-ae68-04c86a518ea4 1.633s
2016-01-04 14:51:43,337 847 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'date': 'Mon, 04 Jan 2016 19:51:42 GMT', 'status': '204', 'connection': 'close', 'content-length': '0', 'x-openstack-request-id': 'req-ca993a48-7a0e-4347-b47b-3f3d1a269ee6'}
        Body:
}}}

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/api/network/test_ports.py", line 110, in test_create_port_in_allowed_allocation_pools
    body = self.client.create_port(network_id=net_id)
  File "/home/stack/tempest/tempest/services/network/json/network_client.py", line 139, in _create
    resp, body = self.post(uri, post_data)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 252, in post
    return self.request('POST', url, extra_headers, headers, body)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 629, in request
    resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 685, in _error_checker
    raise exceptions.Conflict(resp_body)
Conflict: An object with that identifier already exists
Details: {u'message': u'No more IP addresses available on network 96779667-fe9c-4b38-bd4f-eda08eea0f6f.', u'type': u'IpAddressGenerationFailure', u'detail': u''}
Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout


https://github.com/redhat-openstack/tempest/blob/master/tempest/api/network/test_ports.py
Comment 2 wes hayutin 2016-01-04 16:18:49 EST
The following test fails for the same reason

tempest.api.network.test_ports.PortsIpV6TestJSON.test_create_port_in_allowed_allocation_pools
Comment 3 Mike Burns 2016-01-04 16:20:51 EST

*** This bug has been marked as a duplicate of bug 1295564 ***

Note You need to log in before you can comment on or make changes to this bug.