Bug 1295597 - mongodb IPv6 disabled because configuration does not include net.ipv6 option
mongodb IPv6 disabled because configuration does not include net.ipv6 option
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jay Dobies
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 19:33 EST by Dan Sneddon
Modified: 2016-04-26 10:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 16:15:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Sneddon 2016-01-04 19:33:12 EST
Description of problem:
In the OpenStack puppet modules for mongodb, the value net.ipv6 is unset. This means that IPv6 is disabled in MongoDB. Native IPv6 is under development for OSP, but in order for that to work we need to enable IPv6 in MongoDB.

Version-Release number of selected component (if applicable):
OSP 8.0 trunk, RDO upstream

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud using IPv6 native network templates
2. Network is deployed with IPv6 addresses


Actual results:
MongoDB ignores the bind_ip in /etc/mongod.conf because net.ipv6 is unset

Expected results:
MongoDB should accept an IPv6 bind_ip so it will work in native IPv6

Additional info:
This can be a value which is set to false by default, but we need the ability to set this value to true. Once that exists, Heat can output "True" if the bind_ip is IPv6, or "False" if the bind_ip is IPv4.

From the MongoDB docs:

net.ipv6

    Type: boolean

    Default: False

    Enable or disable IPv6 support and allows the mongos or mongod to connect to the MongoDB instance using an IPv6 network. All MongoDB programs and processes disable IPv6 support by default.
Comment 2 Dan Sneddon 2016-01-04 19:34:10 EST
Upstream bug filed as well:
https://bugs.launchpad.net/puppet-ceilometer/+bug/1531032
Comment 3 Dan Sneddon 2016-01-05 15:37:07 EST
Upstream bug in Puppet labs bugtracker:
https://tickets.puppetlabs.com/browse/MODULES-2946
Comment 4 Dan Sneddon 2016-01-05 15:37:50 EST
(In reply to Dan Sneddon from comment #2)
> Upstream bug filed as well:
> https://bugs.launchpad.net/puppet-ceilometer/+bug/1531032

This bug was rejected on the Launchpad site, and I was asked to file a bug with Puppet labs, see comment #3 for external bug URL.
Comment 5 Dan Sneddon 2016-01-06 16:15:06 EST
(In reply to Dan Sneddon from comment #4)

This is not actually a bug in the puppet modules, but rather missing data from the TripleO Heat templates. I closed the upstream bug, and made changes to T-H-T to accomodate.

Note You need to log in before you can comment on or make changes to this bug.