Bug 1295649 - Failed to enable repo on WebUI as "undefined method `valid_substitutions` in katello"
Failed to enable repo on WebUI as "undefined method `valid_substitutions` in ...
Status: CLOSED DUPLICATE of bug 1295572
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 00:48 EST by Liushihui
Modified: 2017-02-23 14:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 08:57:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
manifest.zip (212.90 KB, application/zip)
2016-01-05 00:48 EST, Liushihui
no flags Details
attachment1 (142.41 KB, image/png)
2016-01-05 00:50 EST, Liushihui
no flags Details
attachment2 (145.61 KB, image/png)
2016-01-05 00:51 EST, Liushihui
no flags Details

  None (edit)
Description Liushihui 2016-01-05 00:48:56 EST
Created attachment 1111710 [details]
manifest.zip

Description of problem:
In satellite webUI, When enabling a repository set, it will show error info as the following, failed to enable any repo:
"There was an error attempting to enable or disable this repository:
undefined method `valid_substitutions?' for #<Katello::Util::CdnVarSubstitutor:0x0000000f8069e8>"

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20151218.0
katello-2.2.0.16-1.el7sat.noarch
foreman-1.7.2.50-1.el7sat.noarch
candlepin-0.9.49.9-1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open satellite webUI,import the manifest in attachment
2. Go to Content--> Red Hat Repositories-->RPM, extend any Product, enable any repository

Actual results:
1. It will show error info, please see the screenshot1 in attachment.
"There was an error attempting to enable or disable this repository:
undefined method `valid_substitutions?' for #<Katello::Util::CdnVarSubstitutor:0x0000000f8069e8>"
2. As failed to enable repo, click on the "see the related failed task.", It will show "Enable" task is failed.please see the screenshot2 in attachment.
 
Expected results:
Success to enable any repo in satellite webUI

Additional info:
Comment 1 Liushihui 2016-01-05 00:50 EST
Created attachment 1111711 [details]
attachment1 [details]
Comment 2 Liushihui 2016-01-05 00:51 EST
Created attachment 1111712 [details]
attachment2 [details]
Comment 4 Brad Buckingham 2016-01-15 08:57:07 EST

*** This bug has been marked as a duplicate of bug 1295572 ***

Note You need to log in before you can comment on or make changes to this bug.